Support » Fixing WordPress » Add Media Button not working

  • I was told to start my own thread, but I’m not clear on why. I was one of ten posts, all saying the Add Media button does nothing. There’s no result to describe. It just does nothing. But clearly WP knows this is an issue, so I’m a little confused with the new thread thing. But I don’t really know how things work here.

    So I’m not sure what I’m supposed to do. If there are steps I should take, please let me know. The Master List, that I was told to read first, to follow the steps, mentioned Add Media twice on the whole page, and once it talked about it as if it worked. The second was at the very bottom of the page, where it simply states the button does not work. So again, I don’t see any steps I’m supposed to perform.

    I saw a “resolved” post regarding this problem. The poster said he uninstalled some plugins – but he didn’t say which ones! And the thread is closed, so I can’t ask him which ones those were.

    If there’s anything else you need to know, let me know as well. Here’s a link to my site in case you need it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator kmessinger


    The suggestions on the trouble shooting page should all be tried. You have a javascript error so you need to go thru the steps.

    Thank you for telling me what my error was. The troubleshooting page doesn’t actually say that the problem with the Add Media button is a javascript error. So I had no way of knowing what was wrong.

    One of the first things the Troubleshooting Master List tells me to do is to deactivate all my plugins. My problem is last time I tried to deactivate a plugin, I couldn’t.

    When I tried to deactivate a plugin this week, it got blocked by the firewall (WP Firewall 2, v. 1.3). So I tried to deactivate the firewall (whitelisting the page in the Firewall Alert did not work) and it won’t deactivate. Hitting Deactivate takes me to my homepage. Hitting settings reloads the Installed Plugin page. I’m now thinking of renaming the firewall Chucky.

    So I need to figure out how to deactivate my plugins when my firewall won’t let me and I can’t shut the firewall off.

    By the way, today when I try to Save a draft or see a Preview, I got a page that says ‘Are you sure you want to do this?’ and a link to Please try again. I’ve never seen this message before. They could at least give me the opportunity to click something that says Yes! But no. I just can’t continue with my blog post at all. I don’t know if this is related to the rest of my issues.

    My site is

    Moderator kmessinger


    There is also support for your theme at

    That firewall plugin is very old and should never have been installed. Rename your plugins folder plugins-old. That way none of them will load. Before doing that go to the cache plugin and turn it off.

    The error message you are seeing can be caused by an errant plugin(s).

    Thank you, kmessinger. I hadn’t thought to go to my theme support, since this was a WP issue.

    I didn’t know that was an old plugin. Is there a popular, current firewall plugin?

    I’m afraid I don’t know what you mean by going to ‘the cache plugin’ to turn it off – by it, you mean the firewall plugin? Or do you mean the caching plugin – I have WP Super Cache. Ok, I think that’s what you mean. So I’ll shut off WP Super Cache, then figure out renaming a folder…

    That’s right, I’m not a coder, designer, or anything like that. Just feeling my way around here.

    I appreciate your help.

    Ok, I might have found the right folder. I’ve shut off the cache plugin. But then what? Is this when I turn on the plugins, one by one? Won’t they not work, because I’ve renamed the folder? Sorry, but I don’t have a deep understanding of this part of this.

    Moderator kmessinger


    If renaming the plugin folder solved the problem then we know it was one off those. You can create a new plugin folder and add the plugins one by one until the bad one shows up. Or rename the original plugin folder back, disable all plugins and add one by one – save the cache for last.

    Is there a popular, current firewall plugin?

    Not sure. Did someone recommend you do this? This is what wp recommends

    I was actually able to deactivate the Firewall plugin tonight, which enabled me to deactivate all the others. I’ll now go through the process of reactivating and seeing when an error pops up.

    I’m a little confused by the page you sent me to. The section about Firewall plugins refers to two – one of which the page doesn’t load. The other is WordPress Firewall. I had been using WP Firewall 2. Same name, just v. 2. Not the same plugin? A little confusing.

    Also, when I search from within my dashboard, this plugin, WP Firewall, by SEO Egghead, does not come up in the list. The top three are OSE Firewall (v. 1.0.2, 5 stars but only 6 ratings), 6 Scan Security (v. 3.0.1, 4 stars from 54 ratings), and WP WAF (v. 1.0, 5 stars from 4 ratings, not tested w/ WP 3.5 — is this the one referred to on the page in the link?)

    I definitely would choose the 6 Scan plugin from those stats, esp. since it’s been downloaded over 35k times. Is there any reason I shouldn’t use this plugin for my firewall?

    Thank you for your help.

    MK Slider – Plugin clashes and causes this problem.

    I nixed it and it all started working wonderfully again.

    Disable it, and anything else which resembles a fancy slider.

    Good hunting.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Add Media Button not working’ is closed to new replies.