Support » Fixing WordPress » Add Media button not working

  • When I go to a new post and click the Add Media button nothing happens. Also when I try to click on “quick edit” on a draft.

    I notice I can ‘right click’ on the upload/insert media button and it will load in a new window but it just adds it to ALL media and not to the specific post.

    I just upgraded to the latest version of WP from earlier one but it was happening in that one as well -just today though. I deactivated all plug-ins to see if there was an issue with those but it didn’t make a difference and they are all up to date.

    Any help would be greatly appreciated.

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi


    Forum Moderator

    Have you tried:

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    Hi All

    Happy New Year.

    Yet again, I’m going to jump on the add to media button not working.

    Has anyone come out with a fix for this yet or maybe pull WordPress 3.5 until this has been fixed.

    Is there anyway to roll back to an older version of wordpress?

    Thanks in advance.


    This is really annoying… I upgraded to WP 3.5 and all of a sudden my add media button in posts no longer work. Please help.

    I am having the same issue the add media button is not working on my 3.5 install. I have deactivated all plugins and this does not help. I am also experiencing problems with the button that turns the editor to full page.

    Any quick fix on the way?

    having same problem 🙁

    Well after some investigation I have solved the problem. I changed my theme, form one called Arunja to one of the WordPress default themes. The problem was fixed immediately. I have added all my usual plugins and things are fine.
    I have manged to upload media etc. The new theme 2011 I think is working fine, with some custom headers photos.

    I have also changed themes and the problem of adding media disappeared as well. I actually like the new theme better than the old one, but this was an annoying problem.

    Moderator Andrew Nevins


    Forum moderator

    Wmlulow, if you’re not contributing towards the original poster, continue on your own thread.

    I’m having the same problem. Is the only solution to change themes? Right now I just want to finish a post. But I can’t add an image no matter what I do. I don’t have time to be messing around with theme changes.

    This is really, really annoying. Upgrading is supposed to be an improvement, not break buttons.

    I’m having the same issue

    Same issue here. Add media not working, tried adding new images in my media library manually which worked, but it cannot be accessed through a post when I try to upload a selected image.

    @monica and @pisforprops and @freedomwritersca – please start your own threads after reading this post and starting on the steps discussed therein:

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Add Media button not working’ is closed to new replies.