Support » Fixing WordPress » Add Media Button doesn't work

  • Chrome Version 23.0.1271.97
    Firefox Version 17.01

    uninstalled all plug-ins, reset to default theme, re-installed WP, the entire works. I press the button and nothing happens.

Viewing 15 replies - 1 through 15 (of 15 total)
  • It can be a hosting issue that breaks javascript. There is a bug ticket for it.

    You can try to use define(‘CONCATENATE_SCRIPTS’, false); in your wp-config.php file. This will stop loading all javascript files in one file.

    That fixed it, sure enough.

    WordPress 3.5.1 will hopefully be released early next month and that can fix your issue. Till then use this and try again when 3.5.1 got released

    3.5.1 is out and doesn’t fix the problem 🙁

    I can confirm that 3.5.1 does not fix the issue. Interestingly, a fresh install of 3.5.1 with twentytwelve theme works for a certain period of time, (no metrics unfortunately), then the “Add media” button displays the add media screen, but no images (images that you know are there because they can be seen in the media library from the dashboard). Also, upload of an image displays an error, but the upload is actually successful (because the file is there when you look for it on the file system).

    Obviously, all concerned would really appreciate any information that may fix this problem.

    I will going to ask around what the current status is. I’m pretty sure we fixed some of the issues.

    Rayfox: It seems that uploading an image is a second problem and I tested this out on several systems without ever seen that issue. Maybe the image was too big to handle.

    Hi, same problem for me.

    inoxys – if you need help, please see this thread:

    and then start your own thread. Please also include the relevant information in your post.

    Marko – thanks for your reply. I have tested add media on at least 10 installations of WordPress 3.5.1 on differing configurations and themes. Your comment about image size is valid but I have tried with many different sized images. The existing images (of all sizes but never larger than 4MB) do not appear for selection.

    I have tried your suggestion: define(‘CONCATENATE_SCRIPTS’, false); in the wp-config.php file with no success.

    I am using WordPress to teach 43 students about website startegy and design, so I have many test possibilities and anm willing to try any fix that is suggested.
    Again I think it’s interesting that a clean install works, then after a certain time it stops working. Not sure if this means that there is a time element in the mix.

    I am experiencing the same issue with my website. Since downloading the newest version of WordPress 3.5.1, I cannot add media to my pages. Does anyone know how to resolve this problem?

    Same problem – BUT it only seems to apply to my HOME page. I click the ADD MEDIA button, but nothing happens.
    On all the other pages I’ve tried the ADD MEDIA button works OK. (And it works if I crete a NEW PAGE too!).

    I’m using the Sold! template, with:
    – Event Espresso (which I hate as it’s ugly and clunky!)
    – WooCommerce

    Any tips welcome!

    @matthk – if you need help, please see this thread:

    and then start your own thread. Posting in another person’s thread, even if it seems like you have the same issue, is not a good way to get help here.

    I do not have a solution but I have found a workaround. I installed the plugin “Faster Image Insert”. At least it allows population of the gallery for a page and images can be inserted to a page while you’re editing it (without having to code the img with html yourself)

    @rayfox and @matthk: You have a plugin breakage issue. So some plugin breaks the javascript.

    @matthk: So you don’t have the same issue. You only think so. It’s quite interesting that you somehow complain about the loudest ones get the attention since you are one of them. Starting your own thread makes forum clean and readable. And in your case your clients are right. So if you still have an issue then create a new thread.

    I was helping out in this topic. If WPyogi didn’t said it before me I would have. And as far as I can tell in every forum this rule is there. Hijacking a thread is just lame and disrespectful. Also you can dare whatever you want. I don’t know you and you don’t know me.

    So if it isn’t a plugin then it is the theme. There is no line of code in WordPress that makes an exception on a certain page. So it isn’t inside WordPress but somewhere else. If it was a bug in WordPress it was probably already know in December and fixed for 3.5.1.

    I think we can close this topic now.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Add Media Button doesn't work’ is closed to new replies.