Support » How-To and Troubleshooting » [Resolved] "Add Media" button broken in 3.5

[Resolved] "Add Media" button broken in 3.5

  • Hello-
    I am following the forum’s guidelines to post a new topic rather than bumping another thread.

    I have upgraded to WP 3.5 and the “Add Media” button elicits no response. This behavior began this morning after 3.5 was installed as an upgrade on Wed at 15:25hrs.

    I have
    -disabled all plugins from within the dashboard
    -changed the folder to ‘plugins.hold’ and reversed the process
    -updated all plugins (only really using akisment, anyway)
    -switched to the default template
    -re-installed WP 3.5

    The problem has persisted through all of these steps.

    My site is at http://www.batador.com.

    The site is relatively new and fortunately we have not spun up to full production, so this is mostly a minor (if significantly annoying) problem.

    Please advise. Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • BAM. Fixed it.


    One of the new features for their hosting plan is something called “Page Speed Optimization”.

    This is the “mod_pagespeed” issue mentioned here:


    If you have this issue and you are a Dreamhost customer and you have this feature enabled, this may be your problem.

    Mika Epstein


    DreamHost Rep

    FYI, we’ve got our WP experts and server admins attacking this problem from both ends.

    You can also put this in your wp-config.php instead of turning off page speed.

    define('CONCATENATE_SCRIPTS', false);

    If you’re not on DreamHost, but you use mod_pagespeed and have this problem, I’d love to hear so we can see if it’s just us doing something abnormal, or something more widespread that we need to take to Google. You can email me at mika.epstein @ dreamhost.com 🙂



    Moderator and Editor Customizer

    Thanks Ipstenu!

    I have a few clients who I’ve had to use this with. I’ll find out their hosts and see if I can make a little list for ya!

    Appreciate the attention!

    I have added the

    define(‘CONCATENATE_SCRIPTS’, false);

    script to my wp-config.php file and re-enabled page speed opitimization. I’ll post an update here in a few hours!


    Many thanks @mika E. (Ipstenu at DreamHost)!
    I have Dreamhost hosting with page speed and adding

    define(‘CONCATENATE_SCRIPTS’, false);

    to config.php fixed it for me.

    THANKS 🙂

    It worked

    Thanks 🙂

    Mika Epstein


    DreamHost Rep

    FWIW, I’ve gotten in touch with some other people. It’s definitely not just DreamHost having these issues.

    Mika Epstein


    DreamHost Rep

    As promised, I’m back!

    If you’re on DreamHost, we’ve been rolling out a fix for this, so you don’t have to have CONCATENATE_SCRIPTS set. The issue is Google PageSpeed and how it’s compressing already compressed files (we filed a bug with them, no ETA on a real fix at source). You should be able to remove that line from your wp-config now (or turn pagespeed back up).

    If you find any where it’s still not working, an apache config or config+restart should do the trick

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] "Add Media" button broken in 3.5’ is closed to new replies.