WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] "add media" and 'tags" not working when jetpack is activated??

[Resolved] "add media" and 'tags" not working when jetpack is activated??

  • Yesterday I started getting problems with wordpress when writing a post. The add media and tag buttons were not responsive. Today we deactivated all plugins and reinstalled wordpress and then activated the plugins again.

    I have found that everything works until jetpack is activated again, then it stops working again.

    Does anyone know how to fix these problems?

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 38 total)
  • Plugin Contributor Christopher Finke

    @cfinke

    Can you try this and let me know the results?

    1. Load your blog’s new post page.
    2. Using the Chrome browser, open the “View” menu and select “Developer — JavaScript Console”.
    3. In the newly-opened panel, select the Console tab.
    4. Refresh the page.
    5. Click the “Add Media” button.

    At this point, there may be some errors in the console. Copy and paste them here. If not, let me know.

    I am having the same problem. When Tiled Galleries and/or Carousel are active in Jetpack, the Add Media button doesn’t work. Nothing appears in the console in a New Post when they are inactive. When they are active, I get the following error message:

    Uncaught TypeError: Object function (a,c,d){var e=a.split(“.”)[0],f;a=a.split(“.”)[1];f=e+”-“+a;if(!d){d=c;c=b.Widget}b.expr[“:”][f]=function(h){return!!b.data(h,
    a)};b[e]=b[e]||{};b[e][a]=function(h,g){arguments.length&&this._createWidget(h,g)};c=new c;c.options=b.extend(true,{},c.options);b[e][a].prototype=b.extend(true,c,{namespace:e,widgetName:a,widgetEventPrefix:b[e][a].prototype.widgetEventPrefix||a,widgetBaseClass:f},d);b.widget.bridge(a,b[e][a])} has no method ‘extend’

    Plugin Contributor Christopher Finke

    @cfinke

    deiseach: What is the URL of your site?

    I have the same problem. Had to deactivate Jetpack to add media to my post.

    When I clicked on the media it sometimes worked, but opened in the same window, whereas it normally opens in a pop-up screen.

    There is no problem if Jetpack is activated but not connected to WordPress.com.

    I’m having the same problem as the OP – though I’m specifically interested in adding media to pages rather than posts.
    Following Christopher’s instructions, in the new page screen, on opening the javascript console, the following error is displayed –

    Uncaught Error: Syntax error, unrecognized expression: tr.portfolio_title, jquery.js:2

    After refreshing the page and clicking the add media button, no new errors appear, but no insert media popup appears either, nor does the new page screen move to the media gallery page or similar.

    Hovering over the add media button reveals this URL –
    http://treelocate.com/wp-admin/post-new.php?post_type=page#
    which to me says it’s coded for adding a new page, not a new media element.

    Plugin Contributor Christopher Finke

    @cfinke

    gazouteast: That error wouldn’t be coming from Jetpack; what other plugins do you have installed?

    Plugin Contributor Christopher Finke

    @cfinke

    deiseach: Can you try disabling your other plugins and see if that temporarily fixes the problem? If so, can you let me know which plugin did it?

    Will do. I’ll disable all my plugins except for Jetpack and see what is causing the problem. Thanks for the feedback.

    My problem was with another plugin. I disables them all and just left jetpack and it worked fine. I then activated them one by one thus finding the offending plugin. Many thanks for the assistance.

    I now fee the problem has been resolved.

    Plugin Contributor Christopher Finke

    @cfinke

    paulbienkowski: What was the other plugin?

    Christopher,
    The “portfolio” function is within the theme. As the theme has been in use for over six months and survived quite a few WP core plus many plugins’ upgrades, my money would be on something within JetPack having changed that has now broken a longstanding feature within the theme.

    In particular, the only upgrade run since the add media button last worked, has been Jetpack.

    Given that so many forum threads have been raised about this happening, then I feel the problem is not within all the other plugins and theme functions (of all the users reporting the problem) but within the latest iteration of JetPack.

    Given Nacin’s lengthy investigations in WP 3.5 Beta regarding this topic, and the threads in Trac about the same topic, it could even be that something within the latest JetPack is intrinsically incompatible with WP 3.5 core.

    Shifting the blame to multiple other plugins and themes is therefore just a diversion when the WP core and JetPack are the common denominator for everyone having problems (although this problem did not manifest for me before upgrading JetPack).

    By elimination, everything worked until the latest upgrade to JetPack, ergo the problem is in JetPack.

    I checked out all my plugins and the winner is . . . Simple Slideshow. I suppose it makes sense that the two are not necessarily compatible. Now I know. Thanks once again for your feedback.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘[Resolved] "add media" and 'tags" not working when jetpack is activated??’ is closed to new replies.
Skip to toolbar