Support » Fixing WordPress » Add Link, Stay on this page

  • Steps to reproduce:

    1. Add/Edit a post or page
    2. Write some text and highlight
    3. Click the “Add link” button
    3. Enter a URL and press “Update” button

    At this point it gives me a popup dialogue window and asks me whether to “Leave this page” or “Stay on this page”.

    Neither has the desired affect, the link is not created.

    This is since WordPress 3.2 (including 3.2.1)

    I’ve tested this on 3 WordPress sites, all have the same issue.

Viewing 15 replies - 1 through 15 (of 15 total)
  • I had this same issue on a dev site I updated to 3.2

    I have just tried it on another dev site that is updated to 3.2.1 but on this site it works fine. I cannot reproduce it.

    I am using Chrome 11.0

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Have you tried the default troubleshooting steps?

    1) Turn off ALL plugins.

    2) Switch to teh Twenty Eleven theme.

    I just posted the same issue but not willing to change themes…is that the only way to fix the problem or is this just for troubleshooting?

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    It’s for troubleshooting. We can’t magically know what’s wrong with your site unless you try things, so if you’re not willing to change your theme, you’re out of luck.

    Seems to be an issue in the Koi theme for me.

    I have a similar issue, but I do get the prompt however to stay on page or nav away though, it just simply never creates the link. Have tried the basic steps of disabling all pluggins and using the twenty eleven theme (simultaniously). No change in results.

    Wordpress – 3.2.1.
    Apache – 2.2
    OS – Win7 Pro (SP1)
    MySQL – 5.5
    PHP – 5.3.6

    correction: i DONT get the prompt to nav away (for some reason i cannot edit my original post)

    Bump! I even created a brand new site from scratch on a different host platform, and STILL have the same issue. Can someone from support please look into this.

    New platform Versions:
    Wordpress – 3.2.1.
    Apache – 2.2.19
    OS – Linux (not sure what flavor or version)
    MySQL – 5.1.56
    PHP – 5.2.17

    I’m having the same issue. Tried 3 different browsers: Firefox, Chrome and Safari (all on Mac). I just updated to 3.2.1 and am now unable to add a hyperlink. Please look into this…this is a huge inconvenience. Thanks!

    I can confirm I’m also seeing this, with Chrome 13 and Firefox 5.0

    I tried disabling all plugins and switching to the default theme (Twenty eleven) but that didn’t change anything for me.

    All of a sudden I stopped having the issue but a couple of reloads later here it is again…

    Hope it gets fixed ASAP.

    Thank you!

    Oh, and on top of that I’m experiencing another strange issue:

    The ‘screen options’ don’t seem to work on wp-admin sitewide!

    I think it might be some js / jQuery issue.

    I noticed some errors in the js console (chrome and firefox):

    line 219: Uncaught TypeError: Object #<Object> has no method ‘prop’
    (Chrome 13)

    or also

    line 219: g.prop is not a function
    (firefox 5.0)

    I’m digging deep into the source 🙂

    Ok guys, I found something that works for me… and I’m posting it fyi.

    The problem originated since my theme needs jQuery 1.4.4 while the one WordPress ships which is version 1.6.1.

    I fixed this with a simple edit in my theme functions.php file:

    function fix_theme_jquery() {
    if (!is_admin()) {
    wp_deregister_script( ‘jquery’ );
    wp_register_script( ‘jquery’, ‘’);
    wp_enqueue_script( ‘jquery’ );

    add_action(‘init’, ‘fix_theme_jquery’);

    This simply checks if we’re in the admin panel and if not loads a previous jquery version.

    Hope it will fix it for you as it did for me.

    Thanks for that, this helped me pin down a big I was having with galleries and the image uploader when adding or editing a post.

    The cause was this error being thrown in firebug, which was caused by two different versions of jQuery being used.
    WP itself was using 1.6.2, whereas one of my plugins (Calendar Posts) was using 1.4.2.

    Editing the calendar plugin to remove the import for the 1.4.2 jQuery script fixed all issues I was having, disabling the plugin also worked.

    Looks like perhaps WP should have a more formalised way for plugins to use whatever version of jQuery that WP itself has already imported and used (on the editor / admin side)? This kind of thing is easy to do if you code your plugin to use a specific version of jQuery, and hard to fix when it conflicts with another version.

    @ldwp I’m glad that helped 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Add Link, Stay on this page’ is closed to new replies.