WordPress.org

Support

Support » How-To and Troubleshooting » Add Link Box is Blank. Also Can’t Add Categories

Add Link Box is Blank. Also Can’t Add Categories

  • TomHusband
    Member

    @tomhusband

    If I add a link the add/insert link box is blank. If I click the x it just sticks to the cursor and I have close the window. I had the same thing happen intermittently when I added images too.

    Also I can’t create categories. I create one, hit the add category button and it disappears, nothing is created.

    Here’s my site if that helps.
    http://www.california-travels.com/

    Am I missing a setting somewhere?

    Thanks,

    Tom

Viewing 15 replies - 1 through 15 (of 20 total)
  • I’ve had that happen to me too (the category thing). From what I know, you have to publish a post to the category for them to show on the admin screen (or the front page). Not a lot help but add a category, then switch to write post and with any luck, it’s there.

    TomHusband
    Member

    @tomhusband

    OK thanks ccoupe. So that means I need to post to “unassigned” and then change it? I can’t do that as I can’t add a category because it won’t stick.

    Thanks for the suggestion though.

    Tom

    TomHusband
    Member

    @tomhusband

    Any other suggestions on where I could look to resolve this?

    Thanks,

    Tom

    TomHusband
    Member

    @tomhusband

    It looks like this fixed my categories problem.
    http://wordpress.org/extend/plugins/category-admin/#post-53

    I still have the issue with adding links though.

    TomHusband
    Member

    @tomhusband

    Perhaps a screen capture will help explain what I’m talking about. I highlight the words and click insert/edit link. This is what I get:
    http://www.california-travels.com/wordpress/add_link_blank_box.jpg
    I have to exit to get rid of it.

    Any ideas?

    Thanks,

    Tom

    TomHusband
    Member

    @tomhusband

    OK, figured this one out too, sort of. It’s a work around really. Instead of adding a link on the visual tab I did it on the code tab.

    Still, though, I’d like to know why the add/edit link selection doesn’t work on the visual tab.

    Tom

    Hey TomHusband, we’re having the exact same link problem using version 2.1.2.

    Another user, 3 months ago, had this problem using 2.1.3 and apparently fixed it by using the old TinyMCE file from 2.1.2 (my current version).

    My site has a ton of links to be made and I’ve love the visual editor to work…

    TomHusband
    Member

    @tomhusband

    Whew, glad it’s not just me. I get the blank box with both insert link and image in visual.

    I’m using 2.2.1 and found that if use IE rather than FF I can get both to operate correctly.

    Tom

    Tom,

    I’m also having this problem. I hoped that upgrading would fix the problem but it hasn’t. I was using 2.2.1 and I’m now using 2.3

    The link box just follows my cursor and it’s empty.

    I wonder if there is an easy fix for this.

    Hi guys,
    I am using 2.3 and I have the exact problem with the link box. It just stays blank and follows my cursor around. If I use IE7 it works, but not in FireFox.

    Any ideas on why this might be happening?

    -Drew

    Turn off javascript in the browser, then you can add categories. This worked for me in Firefox.

    Has there been resolution on missing ADD LINK button – our search page went kerplewy, then the ADD LINK button went missing too. Would love to fix this, please advise. Our nonprofit group Accuracy&Aesthetics has 2 volunteers waiting to work on inputing links but suddenly unable to utilize their gracious efforts. Thank you.

    Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    These problems are invariably server related. Some servers (notably ones running mod_security) don’t like the AJAX calls that WordPress is using to retrieve the javascripts and the contents of those pop-ups and such. There’s no easy fix, you need to look at your server logs and figure out what http hits the server is rejecting, why it’s rejecting them, and fix that problem.

    If you have mod_security on the server, turning it off would be the only real fix.

    I fixed this by going into myphp admin on my host, choosing the WordPress database, browsing in the wp_options.php and making sure the site url had “www” and wasn’t just “http://sitename.com”; I had to make it “http://www.sitename.com”

    Worked like a charm.

    Joni
    Member

    @jonimueller

    This was driving me crazy. It was a web host issue; thanks, Otto.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Add Link Box is Blank. Also Can’t Add Categories’ is closed to new replies.