Support » Fixing WordPress » Add Link and other popup menu problem

  • Resolved BenActor


    Hi! First post, so I apologise if this is in the wrong part of the forum.

    I’ve got a bit of a problem with adding links in the visual editor of WordPress. When you click on the ‘Inset/edit link’ icon a white light box pops up with a grey bar at the top, but there is nothing in the box at all. I can close it because it seems to close by clicking on the top right hand corner of the grey bar where the ‘Close’ icon should be placed.

    The same problem occurs with ‘Insert / edit embedded media’ & ‘Insert custom character’ icons, but the ‘Help’, ‘Add and image’, ‘Add video’, ‘Add audio’ & ‘Add Media’ icons all work correctly.

    I was using WordPress version 2.8, but have upgraded to 2.9 and the problem had not been resolved. I have also tried this is another blog I run and the same problem occurs (the other blog used 2.8.1).

    This issue seems to occur whether I am using Firefox 3.5.6, Google Chrome 3.0, Safari 4.0.4 or Internet Explorer 8.0.

    I’ve seen there have been similar problems in the past:

    But they seemed to be confined only to Safari in that previous case. But mention it might be a problem with the overlay?

    Here is a screenshot of the problem

    Any help much appreciated!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Looks like a bit of a problem! It could be that the contents of the box isn’t loading correctly. The menu is opening up correctly, and it would appear that it’s not the overlay at fault as otherwise the menu would be greyed out too.

    My suggestions would be:

    • Have you tried clearing the cache in your browser(s) since you upgraded?
    • Try the TinyMCE support forums. The write box uses code written by TinyMCE, not WordPress, however having said that it could be WordPress’s implementation and display coding at fault.
    • Try using your blog on a different computer with a different screen resolution. Perhaps something’s walked off the screen!

    Thanks very much for your reply Ben! Much appreciated.

    I tried clearing out the cache, to no effect. However, thanks to your advice about TinyMCE I managed to find and install a useful little plugin called ‘TinyMCE Advanced’ which has seemingly solved the problem, as well as giving me a few extra options to play with when editing posts.

    So the problem has been solved, and I can do more with my WordPress posts!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Add Link and other popup menu problem’ is closed to new replies.