Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Add Gallery / Images

  • After updating NextGen 3.0.1 version everything functions except this one link which now shows up in admin top bar “Add Gallery / Images”. I now get the error “Sorry, you are not allowed to access this page” when I click on that.

    I’ve reset the entire plugin, deactivated, uninstalled. Deactivated all plugins. Same thing. Using WP 4.9.6

    I also installed this on another website with older 4.9.5 of WP that has a basic WP setup with extra theme and had the same result with NextGEN 3.0.1

    Tried a 3rd site with stock WP and 2016 theme same result of error.

    • This topic was modified 2 years, 8 months ago by Ryan.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support edanzer

    (@edanzer)

    @nayr80 – any chance you could take a screenshot of link you are clicking?

    Also, what’s the URL that’s trying to load after you click the link – the page where the error appears?

    Thanks.
    Erick

    @edanzer

    Link it opens https://website.com/wp-admin/admin.php?page=ngg_addgallery

    View on iPad
    https://www.dropbox.com/s/m2dv4k3po1xjyto/Photo%20May%2018%2C%2010%2017%2049.jpg?dl=0
    https://www.dropbox.com/s/zjveow6pvzksubh/Photo%20May%2018%2C%2010%2029%2052.jpg?dl=0

    The only “Add Images / Gallery” link I see is when I’m in the admin dashboard and on the top. That also brings up another issue, I’m using an iPad right now and on my phone I have no visible link to add images or gallery. The option does not show in the admin section up top on the phone or in the side column on either device. So I can’t add any images through the plugin currently.

    I have not tried this on a desktop yet, away from laptop.

    • This reply was modified 2 years, 8 months ago by Ryan. Reason: Update link

    @edanzer

    A note, “Add Images / Gallery” works on my laptop. It also shows up in the left column menu where it doesn’t on an ipad.

    Plugin Support edanzer

    (@edanzer)

    @nayr80 – I see the issue. The image uploading in NextGEN uses a third party library called plupload. The version we’re using does not support uploads on most mobile devices. Rather than continue to show the link when functionality didn’t work, we hid that link on mobile devices. We just forgot to hide it from the admin bar.

    That’ll be our approach until we can update/adjust that library to support mobile.

    I will say that we considered updating the library for this release. However, we took great care in this already-large release to avoid changing core functionality that could break and/or break other things as well. Given the critical nature of image uploads, we decided to avoid changing the core library for uploads for this release.

    The functionality that’s not working there has been like that for years without much protest, so we didn’t sense it was urgent. That said, it is on our list of upcoming changes.

    Out of curiosity – the fact that you were looking for that on your ipad – have you been successfully uploading images from you ipad in the past?

    Thanks.

    @edanzer

    It has always worked for me on my devices before version 3.0, something is not right with your explanation of it not working. Not supporting mobile devices would be a very bad decision.

    I do all my photo work on my laptop then upload a bunch of photo sets to my web server then I would add images from sorted folders I pre made with my devices. I would use the “import folder” function which is very handy.

    • This reply was modified 2 years, 8 months ago by Ryan.
    Plugin Support edanzer

    (@edanzer)

    “I would use the “import folder” function which is very handy” – I suspect that’s why it was working. The folder functionality should be fine, it’s just the main importer.

    We agree wholeheartedly that we should be supporting image uploads on mobile by the way. It’s not something we took away. It just wasn’t woking before. And there’s not much point exposing functionality that won’t work. And again, we didn’t want to mess with the long-time uploader, which could have all kind of ramifications.

    Once we’re sure the 3.0 release is steady and solid, which it appears to be, we’ll start looking at updating the uploader NGG has been using for years.

    In the meantime, it sounds like in your case the main issue because we’re hiding the whole upload tab, it means the folder portion of that tab, which you were using is no longer visible.

    To fix that, we’d need to more selectively hide only the upload tab until such time as update the uploader. I’ll make an issue for that, and review with team when we can add/adjust that for you.

    Plugin Support edanzer

    (@edanzer)

    Are you adding all your albums at one time within the Insert Gallery Window? If so sounds like when you click to EDIT that album/group of albums, they are stripped?

    If you look at https://monosnap.com/file/yF3vgCXTGJRaT5ASZgpNiddHMMoM7A

    Is that where you are inserting all 103 albums? And is the issue that the albums are not there when you go to edit/add more?

    Plugin Support edanzer

    (@edanzer)

    I do want to confirm that I just tested to this be sure that if I:

    1) Insert an album
    2) Go to edit that album it is still listed in the drop down above.

    I just wanted to confirm that NextGEN isn’t somehow stripping prior inserted albums from that drop down when you go to edit.

    Plugin Support edanzer

    (@edanzer)

    @nayr80 you can post screenshots here as I did above. If you want to send them separately, you can use this form: https://www.imagely.com/report-bug/

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Add Gallery / Images’ is closed to new replies.