Support » Plugin: WPAdverts - Classifieds Plugin » Add form not allow typing

  • Resolved exodor

    (@exodor)


    Category dropdown dont work and ‘Description” box will not allow to insert text…Please help

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Greg Winiarski

    (@gwin)

    To fix the category dropdown go to wp-admin / Appeareance / Customize / Additional CSS panel and add there the code below

    
    .adverts-field-name-advert_category {
        overflow: visible !important;
    }
    .adverts-multiselect-options > label > input[type="checkbox"] {
        height: 14px !important;
        padding: 0px 8px !important;
        line-height: 14px;
    }
    

    I am not sure about the description box it seems to allow typing? What browser you are using to test it?

    Chrome

    Look what happened now when you click on the AD…..

    the single_advert caused that I deleted it and it was fixed

    I tried the site in Firefox, still, I cant enter text in the description box

    Plugin Author Greg Winiarski

    (@gwin)

    There seems to be a JavaScript error coming from wd-facebook-feed plugin, please try disabling it and see if it helps. If it does you will need to ask the plugin author for help. He should make the buttons functional when using the text editor in the frontend or disable the buttons in the frontend at all.

    In the meantime you should be able to use WPAdverts with text editor disabled, to do that add the code below in your theme functions.php file

    
    add_filter( "adverts_form_load", "disable_adverts_tinymce" );
    function disable_adverts_tinymce( $form ) {
      if( $form['name'] != "advert" ) {
        return $form;
      }
      foreach( $form["field"] as $key => $field ) {
        if( $field["name"] == "post_content" ) {
            $form["field"][$key]["mode"] = "plain-text";
        }
      }
      return $form;
    }
    

    Hi Greg,
    I disable the plug in you mentioned and nothing happened. I added the code to the function.php file and it did resolve the problem…:)

    Thank you for the great and fast support !!!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Add form not allow typing’ is closed to new replies.