Support » Plugin: LiteSpeed Cache » add expires headers when using LiteSpeed

  • Resolved yxda

    (@yxda)


    Hi,
    I am using LiteSpeed with Autoptimize and Async JavaScript and I am getting a message in GTmetrix to add expires headers. The website grade is F(34) for this attribute in YSlow., Otherwise my page speed score is A. My web host uses LiteSpeed web servers instead of Apache. Can anyone help how to resolve the ‘add expires headers’ problem indicated by GTmetrix? Can I do it manually with this webserver or should I find rather a plugin? Which plugin would work well with the above plugins? Thanks,

Viewing 4 replies - 1 through 4 (of 4 total)
  • Check if “Cache – Browser [7]” is on. Then your htaccess should have the required entries.

    Thread Starter yxda

    (@yxda)

    Thank you. Now, on second thoughts I am just wondering if I can do anything with it as GTmetrix indicates 6 items with this problem and two items are Google fonts, two are reCAPTCHA and two are Google Analytics. But, it is good to know that I can do such things in Cache – Browser [7].

    Maybe you mean external ressources. This menu is only for local ressources.
    For external ressources it is a little bit complicated. There are different ways. You can try to self host external ressources.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    thanks @scysys

    yes , gg font , recapt ,these are most likely an external resources , you can not put expire header over external resources.

    you could try use localization to localize these external rss to your local then put header over them

    Best regards,

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘add expires headers when using LiteSpeed’ is closed to new replies.