Support » Fixing WordPress » Add an Image

  • Resolved Qliphoth


    Ever since I upgraded to 2.7, on both of my domains, I’ve been unable to successfully upload pictures into my blog entries while writing them. Clicking the “upload image”-link – or any of the four Upload/Insert links, really – navigates me away from the blog entry editor and into a new page, instead of opening a small window on top of my editor.

    If I chose to upload the picture anyway, the “insert image into post”-button leads me to an empty page, not back to my post.

    I’ve noticed a similar problem when I add an image manually. Clicking the image in the Visual editor and clicking the “Edit Image”-icon puts a dark grey cover over the editor as it did in 2.6, but the actual Image Editing window doesn’t show up over it.

    Before you ask; I upgraded to 2.7 by replacing _all_ files in my installation, overwriting everything, not just the newest files. I’ve tried clearing the cache, run different browsers and emptied the /wp-content/uploads/js_cache

Viewing 6 replies - 1 through 6 (of 6 total)
  • This is still a problem, and none of the fixes in the sticky work. Still no suggestions?

    I am having this same issue! I cannot add any images to a post because when I click on the “Add any media” links, WordPress tries to navigate my full window to the file upload screen instead of just popping up a new miniature window.

    Let it be noted that I upgraded to 2.7 around 3-4 weeks ago and the media upload was working fine…until today.

    Recently added plugins are WP Security & Mailpress. I have deactivated & even uninstalled the plugins, but am still having the same problem.

    I have tested this on two computers & am experiencing the same issue on both.

    Please help.

    Matt of

    I switch my editor to HTML and click img and enter the images url. It’s a temporary solution, but it works for me.

    I figured it out.

    It’s caused by the CommentLuv plugin they just upgraded to version 2.6.3 conflicting with WP 2.7. Just deactivate this plugin, or downgrade to 2.6.2 until they release a new update…

    I posted about it in their support forums here and blogged about it here on eJabs.

    Matt of eJabs

    CommentLuv did release version 2.6.4 (per the readme file), and that’s actually what I was using…but it shows up on the WordPress plugins page as version 2.6.3.

    it is v.2.6.4 that is the culprit…we’ll have to wait for 2.6.5 to come out & fix the issue.

    Matt of eJabs

    Inspired by your suggestion, I tried disabling all my addons, and then it suddenly worked. Enabling them one by one, it worked until I enabled WP-Amazon, at which point it stopped working again. It seems I found the culprit in my case.

    Strange how some old plugins and 2.7 seems to have broken the add image-interface in this very specific way.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Add an Image’ is closed to new replies.