Support » Plugin: AMP for WP - Accelerated Mobile Pages » Add AMP in Menu URL

  • Hi Guys,

    Thank you for this Wonderfull plugin, it really makes AMP life a lot easier.
    I will make the time to give you a 5 star review….

    I do have a little challenge regarding URL’s in the menu.
    Maybe you can help me.

    I have “Auto Add AMP in Menu URL” turned on, because I want mobile users to stay on AMP pages.

    I also have “Mobile Redirection” turned on.

    Now, my challenge is the following, in the menu there is a link to an external registration form and since it is in the menu, the /amp gets added after it.
    Problem is that the external registration form doesn’t work because the link is ‘wrong’ with the /amp added.

    Do you have an idea how to disable it for this specific link so the reg form keeps working?

    To see the issue, go to http://resilico.com/amp
    click on the menu and click the register link.
    You’ll be redirected to the external page and you’ll see ‘Error: App not found!’

    It would be nice if you have a solution for this, I’m almost there….

    Thanks in advance,
    Kind regards,
    Robert
    4csmedia.com

Viewing 6 replies - 1 through 6 (of 6 total)
  • OK, I created a work around.
    I turned “Auto Add AMP in Menu URL” off and created a new menu just for AMP.
    I added the menu items as URL’s and added the /AMP behind the url’s except for the URL to the register page.

    Works like a charm.
    This works in my case because the website isn’t that big and has just 5 menu entries.

    Regards
    Robert
    4C’s Media

    HM, I might still need some help.

    After I changed the menu it seems the “Mobile Redirection” isn’t working anymore, although I’m not sure it is related.

    I tried turning the option of and on again, didn’t solve it
    I also cleared the cache (autoptimize, wp fastest cach, cloudflare)
    I do have the page rule set in cloudflare.

    If I do fetch as google for http://resilico.com/amp, I get a redirect warning:
    This URL redirected to:
    http://www.resilico.com/amp/

    That might be an issue, because that page will probably be then redirected again to http://resilico.com/

    Any ideas?

    Regards
    Robert

    Does anyone have an idea why mobile redirect might not work?
    I have this issue on 2 of my websites now and can’t seem to solve it.
    Any suggstions would be welcome.

    Regards
    Robert

    Plugin Contributor ampforwp

    (@ampforwp)

    Hey @4csmedia,

    I apologize for the delay in response.

    Have you updated to the latest version?
    If yes, are you still facing any issues with redirection?

    Regards
    Marqas

    Hello Marqas,
    Yes, I do and I noticed something.
    I have AMP for WP installed on 3 different client sites now.

    What I noticed is that when I have the option “Auto Add AMP in Menu URL” and “Mobile Redirection” both on, the redirection seems to work on a mobile device.

    But as soon as I turn off the “Auto Add AMP in Menu URL” option, it seems to stop working.

    I don’t know if that makes sense to you, but maybe something to look into.

    Thank you again.
    Kind regards,
    Robert

    Plugin Contributor ampforwp

    (@ampforwp)

    Hey @4csmedia,

    That’s strange.

    There is a limitation of help here, so can you please contact us at team@magazine3.com?
    We will debug it and will resolve this issue for sure.

    Regards
    Marqas

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Add AMP in Menu URL’ is closed to new replies.