Support » Plugin: Shashin » Add Album does not function on production wordpress

  • Resolved markpea


    OK, so I tried out Shashin in a multisite/multiuser test WordPress environment and was suitably impressed. Since I use Picasaweb a lot it was a terrific photo display solution. But when, together with the System Admin for my college, we migrated the WordPress code to a new server, somehow the plugin now fails to create a new album using a legitimate picasaweb album URL. This is certainly a local system problem since the same version of Shashin operates correctly on my sandbox site. What I’m not sure is where to look for hints as to what might be malfunctioning. Would there likely be an error message in the Apache error log? (not so likely I guess cos we’re using nginx — hahahahaha). I’m assured that the firewall is set to ‘allow out’ for web traffic, so it seems unlikely to be a firewall issue. Any thoughts?
    Here’s a URL FWIW :

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Mike Toppa


    When you say it won’t create an album, do you get an error message when you try to add it? Also, could you try adding a Google+ album?

    I just debugged a problem someone else was having, which turned out to be caused by their version of PHP being configured to exclude the DOM libraries, which Shashin relies on for adding Picasa albums. So check your PHP configuration for that on the new server (you can call phpinfo(), and look for “–disable-dom”).

    So, this is interesting.
    Whereas, when I paste in a URL from a picasaweb location I just get a blank area returned — the WP menus are still there though. When I use a URL from Google+ to the exact same picasa album I get the following Shashin error:

    Failed to retrieve album feed at
    WP_Http Error: There are no HTTP transports available which can complete the requested request.

    Thanks for suggesting this — I think it may help us pinpoint the problem at the server end.

    BTW, that is repeatable and I get the same error when attempting to access a Youtube feed:

    Shashin Error:
    Failed to retrieve album feed at
    WP_Http Error: There are no HTTP transports available which can complete the requested request.

    Plugin Author Mike Toppa


    Shashin uses the WordPress WP_Http class, which tries multiple methods to send requests for your album feeds. This error means all those methods are disabled in your PHP configuration. See the first paragraph here – you’ll need to enable at least one of the listed methods:

    Thanks Mike — I’m nagging my sysadmin right now and will report back when the issue is fixed.

    The sys admin installed Curl and then restarted and now all is hunky dory. Albums load from both picasweb and google+.
    Interestingly, the php setting “allow_url_fopen: On” does not in and of itself enable Shashin to operate.

    I’ve also been messing with the Youtube feeds. This has to be the easiest way to incorporate a bunch of Youtube clips from a given channel. Exactly what I need to do in the coming semester!
    Thanks for this very professional plugin.

    This topic is now resolved.

    I hope this is the right place for this question. I have 15 galleries and 15 albums. When I added this last (15th album and gallery) it will not display the 15th gallery to add to the album. Is there a limit to the number of albums/galleries that we can have? How can I display the 15th gallery so I can drag it to the 15th album? Thanks in advance. gcd

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Add Album does not function on production wordpress’ is closed to new replies.