Support » Plugin: Email Encoder - Protect Email Addresses » ADA Compliance?

  • gjefle

    (@gjefle)


    Hi – first off, I love your plugin. I’m trying to get my websites as ADA compliant as possible, but when Email Encoder is active, both webaccessibility.com and wave.webaim.org throw out warnings for email links. Disable the plugin and those warnings disappear. Is there a way around the ADA warnings but still keep the emails hidden from bots? Thank you in advance!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ironikus

    (@ironikus)

    Hey @gjefle – thank you a lot for your message and happy to hear you like our plugin. 🙂
    Can you please share some further details on the warnings you receive from the checks?
    For me it’s important to understand what exactly causes the warnings. In case the checkers also try to validate email addresses, then they are basically acting like a “bot” as well, which might be possible, but it definitely requires some custom development.
    Thank you already a lot for your details.

    Hi – easiest for me to show a screenshot for the webaccessibility.com site – https://www.greentech-services.net/stuff/Screenshot-Accessibility-Test.png

    Using wave accessibility, the error it shows is:

    A <noscript> element is present.

    Why It Matters
    Content within <noscript> is presented if JavaScript is disabled. Because nearly all users (including users of screen readers and other assistive technologies) have JavaScript enabled, <noscript> cannot be used to provide an accessible version of inaccessible scripted content.

    • This reply was modified 2 months, 3 weeks ago by gjefle.
    • This reply was modified 2 months, 3 weeks ago by gjefle.
    Plugin Author Ironikus

    (@ironikus)

    Hey @gjefle – thank you a lot for your details, that helped out. So basically the Web accessibility tool also acts as a “bot” that visits your website and reads all the data, so turning off this feature would also turn it off for other bots, which makes it impractical.

    What you can try is to add a title attribute to the anchor () tag and describe there what it is for. Maybe this helps to prevent the message from your screenshot.

    Feel free to let me know if that worked out.
    Thank you already a lot!

    Thanks for the info and suggestion! I’ll give it a try and let you know what happens.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.