Support » Plugin: Activity Log » Activity Log shows Server IP instead of customer

  • Hello,

    the plugin was working fine before the latest update. Now everything is correct except customer IP. It shows my server IP instead of customer. How can we fix this?

    Thanks in advance!

Viewing 5 replies - 1 through 5 (of 5 total)
  • I suggest deleting the plugin and reinstalling it. I’m seeing correct IP Addresses

    Hello Virgil, i did that already i reset the db from setting also but it didn’t fix the issue.

    Are you using any reverse proxies like Varnish in front of your site? What hosting provider are you on?

    Hey Stanislav, thanks for reply. I m with Bluehost, no i don’t use varnish. I disable it. Do you think it something related to cache plugin? I use only wp super cache. Also i use cloudflare (with cache disabled) if that helps.

    • This reply was modified 1 year, 3 months ago by  JohnnieGR.
    • This reply was modified 1 year, 3 months ago by  JohnnieGR.

    I can almost certainly say that Cloudflare is the reason for the behaviour you are experiencing.

    The “fix” for this is for the plugin to look for the “X-Forwarded-For” header, and if that is set, use the IP from that header. This is finicky in itself, because if you don’t use a reverse proxy (like Cloudflare) then you do not want this behaviour, as it would allow users to spoof their IP. So it should be a configurable option.

    Overall, I’d say it’s a little unfair to give one star to the plugin for this particular issue, but I agree that it should be fixed.

    See this article for more info:
    https://support.cloudflare.com/hc/en-us/articles/200170706-How-do-I-restore-original-visitor-IP-with-Nginx-

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Activity Log shows Server IP instead of customer’ is closed to new replies.