Support » Plugin: HashBuddy » Activities page slug isn't reporting correct page

  • Using WP 4.1 and BP 2.1.1. I had to change line 10 in /includes/hashbuddy.php from

    $activity_url = trailingslashit( get_bloginfo('url') ) . BP_ACTIVITY_SLUG;

    to

    $activity_url = trailingslashit( get_bloginfo('url') ) . 'dashboard';

    Despite having the activity page set to the “dashboard” page, BP_ACTIVITY_SLUG was reporting “activity”. This seemed to be the only manifestation of an erroneous activity URL so I don’t think it’s a BP bug.

    https://wordpress.org/plugins/hashbuddy/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thanks! You really helped me out.

    I was having a similar issue (4.1.1 and 2.2.1 with iBuddy theme) The hashtags where generating but clicking on the tag resulted in a “search not found” page.

    I tried your suggestion and got the same result but noticed the URL directory changed from /Activity/Hashtag to /Dashboard/Hashtag

    $activity_url = trailingslashit( get_bloginfo(‘url’) );

    resulted in //hashtag and a successful search result

    Finally I removed the trailingslashit and got a working URL that displays results matching the Hashtag

    $activity_url = ( get_bloginfo(‘url’) );

    Thread Starter archonic

    (@archonic)

    Trailing slash it should just add a slash at the end – but do whatever works!

    IHaveToDoThis

    (@ihavetodothis)

    Hey everyone,

    I’m having a similar issue, in that I want my hashtags to link to other instances it was used on my site, but instead I get a “search not found” page.

    I tried both changes above and nothing manifested. However if you search for a hashtag in my site search bar, it will pull up the correct search results. Currently when you click a hashtag it take you to:

    localhost/mysite/activity/?s=%23hashtag

    The activity is what’s throwing the search off. I need the url to be:

    localhost/mysite/?s=%23hashtag

    So it throws the word right into the search. Any thoughts on how to make that happen? Thanks!

    Thread Starter archonic

    (@archonic)

    I came back to this and tried to set the define BP_ACTIVITY_SLUG in my child theme’s functions.php and no luck. Unfortunately editing the plugin was all I could do to get it working. Rename the plugin and change the name of the folder it’s in so you’re working with your own plugin which won’t update.

    In your case, if you homepage is your activity feed, change line 10 in /includes/hashbuddy.php to this:

    $activity_url = trailingslashit( get_bloginfo(‘url’) );

    No need to concatenate a slug to the url if it’s the homepage.

    IHaveToDoThis

    (@ihavetodothis)

    Hey,

    Yea I tried that to no avail. Even uninstalled the plugin and changed the file before I put it back in the plugins folder. No luck! It’s like the activity is cemented in there lol.

    But thanks for the quick response. Much appreciated!

    Thread Starter archonic

    (@archonic)

    I made a gist here:

    https://gist.github.com/archonic/e49de88b4619f181f56d

    With the plugin installed and activated, try replacing /wp-content/plugins/hashbuddy/includes/hashbuddy.php with that file, but remove

    . 'dashboard'

    around where the comments say to do that.

    IHaveToDoThis

    (@ihavetodothis)

    Ahhhh!! It worked!! You are the man! Thanks so much for taking the extra time to help me out. I’m still a newbie at all of this so it just really means a lot.

    Thanks again friend!!

    yep this works.
    thank you !

    Thread Starter archonic

    (@archonic)

    Remember that if there’s an update released for Hashbuddy, it may override this change and break your hashtag urls. You could change the name of the plugin so it doesn’t see updates for it anymore, or you could try getting to the bottom of the BP_ACTIVITY_SLUG issue. I still don’t know why it wasn’t listening to the BP page settings or being set when I deliberately set it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Activities page slug isn't reporting correct page’ is closed to new replies.