Support » Plugin: Getwid - Gutenberg Blocks » Active links in slider previews

  • nickfmc

    (@nickfmc)


    It would be nice if any links inside a post slider for example didn’t work inside the block preview window, it’s really annoying for a client to click on a block and be taken to a post because they clicked on a linked image or something like that. just some sort of .removeAttr(‘href’); function within the preview would be so nice. Just a thought

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support eugenewhite

    (@eugenewhite)

    Hello there.

    I sure pass the information to our developers for them to consider the improvement implementation, but would you be so kind to clarify which “preview window” you’re referring to? I’m not sure I got it.

    Thread Starter nickfmc

    (@nickfmc)

    Sure, I just mean inside the Gutenberg editor, say you have a post slider and you have the image/title set to link to the post. When you are editing the page an you go to click on the block to make edits to it, you have to be careful where you click because you have to click on a block to edit it but if you accidentally click on the linked image you get taken away from the editor, which is really bad UX for a user just trying to select a block. Does that make sense? I can send a video if not

    Plugin Support eugenewhite

    (@eugenewhite)

    Hello there.

    Sorry for the late response.
    Thank you for your response and clarification. I do agree that such a block behavior is pretty much unacceptable. But I would also like to inform you that from my side it seems to be working properly. Nothing is linked when I add a “Post Slider” block and select to display my posts, which, obviously, have featured images and linked titles on the front end. Nothing is clickable in the editor.

    So either there’s something else that needs to be done to reproduce the issue or the reason for such an issue to appear is somewhere on your site.

    Thread Starter nickfmc

    (@nickfmc)

    There is something here for sure, I’ll try and narrow it down when I have time but my read more links and a linked image are both clickable from the backend preview. it is only certain sliders I’ve setup that have this issue not everytime, so I’ll try and get you a bit more info soon.

    Plugin Support eugenewhite

    (@eugenewhite)

    Hello, there!

    I hope you’re doing well.
    I would just like to ask you if you have any updates on the matter of this issue and whether the topic may be resolved or not.
    Thank you!

    Thread Starter nickfmc

    (@nickfmc)

    I could give you access to a div site next week after launch. this is not very helpful, but I put my theme to 2022 and tested and this is when I’m hovering a link inside the slider. https://imgur.com/6uUD8D3 and a preview of my template layout. both the image and the read more are clickable. I’ve been setting my blocks to re-usable blocks because this way at least those links become non active in the back end for my clients.

    Plugin Support eugenewhite

    (@eugenewhite)

    Hello there!

    Sorry for the late reply.
    Yes, it would be helpful if you submit a ticket on our support platform and provide us with temporary access to your back end since I tried to reproduce the issue once again and can say everything seems to be working properly, even on the 2022 theme. And also, it’s not clear how you managed to add the “Read More” tag to the “Post Slider” block. So I think that you probably used the “Post Carousel” block instead, but this still doesn’t explain why there are clickable elements on the back end.

    Thread Starter nickfmc

    (@nickfmc)

    sorry you are correct it was the post carousel block. I sent access through to your support email!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.