Support » Plugin: WP RSS Multi Importer » Active Feeds Not Publishing

  • Resolved craynkshaft


    Hi Allen, we emailed about this, but adding a thread just in case others may be encountering similar.

    I’m using your plugin for 21 different feeds, but several of them aren’t publishing even though the feeds are creating new XML results and they’re visible when I preview the feeds in your plugin. They also all have a green checkmark next to them. There seems to be some sort of backup that perhaps has to do with the Fetch Quantity Settings?

    Here’s an example of a feed that has a green check next to it, but isn’t auto-posting to my site:

    I have “Number of Items per Feed to Fetch” set to 80 (though I’ve tried many other quantities) and “Total Number of Items per Fetch” set to 2000. With that math, I should be able to get the 80 latest results from 25 different feeds.

    As a side note, I’m certain I’m not taking every scenario into consideration, but for my needs, are both of those options necessary? Seems like you could avoid some confusion by just have “Number of Items per Feed to Fetch” and ditch the “Total Number…” field. Just a thought.

    At any rate, any ideas why this isn’t working? I’ve tried changing the feeds to Pending, removing and re-adding feeds, but still no dice. It also isn’t limited to the most recent feeds–some old feeds and some of the newest feeds work–I don’t see the rhyme or reason why some work and some don’t.

    Also, not sure if this has anything to do with it, but in the Category Mapping, I have a couple of empty categories that I’m no longer using–I don’t see a way to remove unused categories.


Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Allen


    Well, the first thing is that while the checkmark means that a feed can be found, it doesn’t mean the feed is valid. I think this is happening with all the feeds you are having problems with. Go here and check the feed

    As far as I know, the beta version is working fine as long as the feeds are valid. In your case, many of those feeds, I think, are not valid which is why you don’t see them showing up. This is not due to the fetch quantity or anything like that…it has to do with valid feeds.

    Hi Allen

    I’ve been using the plugin for a couple of weeks and really like it. I have it on 2 sites. On one, my busiest,it seems to have stopped working. I have about 30 feeds being pulled 1x daily and up until yesterday things were moving along well. Then, nothing.

    On another site the plugin is working well, although it seems i have fewer stories than usual (however this is subjective and could be wrong).

    It seems doubtful that all feeds would become invalid overnight.

    I have not added any new plugins.

    The sites in question are:

    1) (plugin stopped working)
    2) (plugin working still).

    Plugin Author Allen


    are you sure the feeds are valid feeds?

    Jumping back in here. This sounds very similar to my issues. I thought it was invalid feed issue Allen mentioned, but I just had a developer adjust each of my feeds so now they all appear valid in the validator he linked to above–and still the same issue. Feeds trickle in and sometimes stop altogether.

    The preview of the latest feed items in the Feed List is correct, but those latest items haven’t posted to my site. It’s set to “Every Ten Mins” and I also clicked on “Click to fetch new feeds” (no new feed items to add).

    I feel like this has to do with backups caused by the Fetch Quantity Settings. Allen, thoughts on it?

    I’m running into similar issues. I just installed the plugin, and am adding feeds. At some point it just stops adding posts. I can even delete all posts created with the plugin, go into the ‘Feed to Posts Settings’ tab and click the ‘Click to Fetch Feeds Now’ button and it won’t even grab the posts that it previously had on the feeds that were known to be working at one point.

    I am using feeds generated from an install of Tiny Tiny RSS, which generates feeds like:

    (this is not a feed I’m using, and the key will be regenerated once we resolve this, but it validates as valid Atom 1.0 feed, just like the others I’m using from the same install of Tiny Tiny RSS)

    Hi Allen,

    My feeds are valid and now both implementations of the plugin are malfunctioning. Below I will paste the error code returned when I fetch the feeds manually. There are many feeds (and thus many errors) so here I will only paste in a small percent to give you some insight.

    I am using version 2.66.4 of the plugin, and WP version 3.6, the latest version according to WP.

    Note the plugin was working until today on this site, and it went on the fritz a few days ago on another.

    Here’s the error reporting:

    WordPress database error: [MySQL server has gone away]
    select post_id from wp_postmeta where meta_key = ‘rssmi_source_link’ and meta_value like ‘%’

    WordPress database error: [MySQL server has gone away]
    select post_title from wp_posts where post_title like ‘%Bob Shavelson at Salmonstock%’

    WordPress database error: [MySQL server has gone away]
    INSERT INTO wp_posts (post_author,post_date,post_date_gmt,post_content,post_content_filtered,post_title,post_excerpt,post_status,post_type,comment_status,ping_status,post_password,post_name,to_ping,pinged,post_modified,post_modified_gmt,post_parent,menu_order,guid) VALUES (1,’2013-08-20 12:43:00′,’0000-00-00 00:00:00′,'<p>Check out this video Inlet Keepers Exec Dir. Bob Shavelson spoke at Salmonstock 2013 explaining to everyone at Salmonstock why they were there. Chuitna, HB77, No Pebble – the fight is varied but together we can win.</p>\n<p>Go to for more info.</p>\n<p></p> …read more <p>Like this? Get more, directly, via :</p>’,”,’Bob Shavelson at Salmonstock’,”,’pending’,’post’,’closed’,’open’,”,”,”,”,’2013-08-20 12:43:00′,’0000-00-00 00:00:00′,0,0,”)

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM wp_posts WHERE ID = 0

    I am also having this issue. Everything was working fine until I updated the plugin a few hours ago. I noticed recent posts were not importing, so I deleted all posts through the plugin and tried to Click to Fetch Feeds Now, and it says there are no new feed items to add. Deleting previously worked… seems something is off on the plugin update.

    Hi, I have the same issue, after last update, my feeds did not come throught.. Any ideas? Or do you have link to previous version of RSS Multi Importer to download it? Thanks

    Plugin Author Allen


    Plugin Author Allen


    let me know if this using this prior version solves the problem…that’s the only way I can diagnose what might be going on.

    Hi, after installing version 2.66.3 is everything working fine. Thanks

    HI Allen,

    What’s the process for replacing the new version with the old, to retain settings and feeds? I have this on two sites and have already undone everything on one, by disabling then deleting (figuring the database fields would be retained).



    I tried reverting back to 2.66.3 to no avail–still not fetching feeds. It’s now almost completely stopped up. Several items were fetched when I first ran the plugin and over time it’s slowed to now only getting one feed item every few hours (skipping over ~50-100 new feed items).

    Plugin Author Allen


    Here is how you retain the settings, by commenting out some lines in the uninstall

    As for 2.663, if this isn’t working, I’m not sure what to say – I haven’t heard of any problems with that version…since you have so many feeds, it’s hard to isolate why you’re having any problems here.

    VERY happy to report 2.665 is working again with one of my domains. I will check the other and will report if there are problems

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Active Feeds Not Publishing’ is closed to new replies.