Support » Fixing WordPress » Active bookmark in Firefox doesn’t work

  • Resolved Thort

    (@thort)



    Hi!

    It is not possible to add an active bookmark to my blog in Firefox. Firefox returns an error message saying it can’t update the bookmark.

    Adress: http://thort.se/blog

    Where do I start looking for a solution?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The problem is with firefox —

    I downloaded your feed to my computer (you can do this by going to /feed/atom/ on your site), and when I look at it directly in firefox, I get an error —

    XML Parsing Error: undefined entity
    Location: file:///home/geoff/var/downloads/ax1gnxga
    Line Number 44, Column 15: <dc:subject>V&aring;rvinter vid Tjol&ouml;holms slott</dc:subject>

    specifically — the <b>&aring;</b> ‘å’ is not recognized by firefox. And yes, it should be!

    So first, you can complain to the firefox development team.

    But in the meanwhile, the question becomes — is there some way of not using entities when they represent valid UTF-8 characters. And the answer is…I dont know, but I doubt it.

    Okay, I think I’ve got a good ‘work-around/bug-fix’ [firefox seems to be interpreting the atom+xml mime type definition a bit differently than I — and they are probably right, considering the definition is written gobbledeegook]

    Anyway, the patch — edit the file ‘includes/default-filters.php’

    Near the bottom, you will see a section like this:

    // RSS filters
    add_filter('the_title_rss', 'strip_tags');
    add_filter('the_title_rss', 'ent2ncr', 8);
    add_filter('the_content_rss', 'ent2ncr', 8);
    add_filter('the_excerpt_rss', 'convert_chars');
    add_filter('the_excerpt_rss', 'ent2ncr', 8);
    add_filter('comment_author_rss', 'ent2ncr', 8);
    add_filter('comment_text_rss', 'htmlspecialchars');
    add_filter('comment_text_rss', 'ent2ncr', 8);
    add_filter('bloginfo_rss', 'ent2ncr', 8);
    add_filter('the_author', 'ent2ncr', 8);

    Add:

    add_filter('the_category_rss', 'ent2ncr', 8);

    (and make sure to reload your ‘live’ firefox bookmark — open the bookmark menu, and right-click on the entry for your feed)

    Thanks thunderlove!

    I do appreciate your concern in my problem!

    I edited my includes/default-filters.php as you suggest.

    I added add_filter('the_category_rss', 'ent2ncr', 8); according to your instruction.

    Then I tried to reload my ‘live’ firefox bookmark, but it didn’t help. The bookmark don’t update.

    One interesting thing. I opened up Opera 8.5, and here I could add an atom channel for my blog. So, bookmarking works in Opera but not in Firefox. (I use Firefox 1.5.0.1)

    I have an english version of my blog. The address is: http://thort.se/photoblog

    When watching this blog in Firefox it is possible to add an active bookmark which is working okey. Both of my blogs use the same Theme.

    As I said, I appreciate your help, and if you have some more suggestions I would be thankful.

    Thor

    Hi again !

    I Just want to report how my problem was solved.

    Some time ago I changed the titles of my posts. I changed the swedish letters “a” with a ring over, “a” with dots over and “o” with dots over. I changed them to “& a r i n g ;” “& a u m l ;” and “& o u m l ;”. My thought was foreign webbrowsers would show the unusual swedish letters wrongly.

    I didn’t foresee the problem this would cause in Firefox concerning the live bookmark.

    So, now I have undone the change I maid.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Active bookmark in Firefox doesn’t work’ is closed to new replies.