Support » Plugin: WooCommerce Catalog Booster » Activation problem, custom URL parameters and quick view

  • Hello,

    I have one problem. When I activate the plugin, it does not appear because WooCommerce is not found. The plugin is installed and activated but I use the Swift Security plugin that hide wordpress and plugins.
    So I change the test to always activate the plugin as soon as I activate it in the back office.
    Is there any solution to avoid this problem ?

    I change the product button to have metas as parameters in the URL. So if I add any meta name in the URL inside {}, then the value is inserted inside the URL.

    function ic_woocat_show_button() {
    	$ic_woocat = ic_woocat_settings();
    	if ( !empty( $ic_woocat[ 'button' ][ 'enable' ] ) ) {
    		$url = ic_woocat_get_button_url();
    
    		$metas = get_post_meta(get_the_ID());
    		foreach($metas as $k => $v)
    			$url = str_replace('{' . $k . '}', is_array($v) ? $v[0] : $v, $url);
    		
    		if ( !empty( $url ) ) {
    			?>
    			<a href="<?php echo $url ?>" class="button"><?php echo $ic_woocat[ 'button' ][ 'label' ] ?></a>
    			<?php
    		}
    	}
    }
    

    Finally, when I click on Quick view, the add to cart button appear in the WooCommerce product quick view lightbox.

    Thank you for your plugin that work great.

  • The topic ‘Activation problem, custom URL parameters and quick view’ is closed to new replies.