Support » Plugin: DD Last Viewed » Activation causes editor to disapear

  • Resolved andrewfitz

    (@andrewfitz)


    Activating plugin and it works great, however all pages and posts admin editor screens are missing the wysiwyg editor. Unable to add new or edit anything with this active. Latest version, and php 7

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Mosterd3d

    (@mosterd3d)

    Hi Andrew,

    Thanks for using my plugin. have you tried to turn off other plugins first to isolate the problem? Do you get any console errors or something? Please provide me with more info.

    Let me know,

    Wouter

    Hi, looking into it. No issues in the console except for missing select2, which I assume is because editor is gone. Also can’t select screen options on the page. Will look for php errors.

    Looks like it could be conflict with avada theme, disabled all other plugins and still had issues on the post page. Disabling their page builder plugin brought up the editor, but there was still issues and wouldn’t let me click tabs.

    https://themeforest.net/item/avada-responsive-multipurpose-theme/2833226

    Very popular theme.

    I had no php errors or wp warnings.

    esinformatica

    (@esinformatica)

    Hello i have the same problem.

    Plugin Author Mosterd3d

    (@mosterd3d)

    Hi there,

    First sorry for this delayed response, but I had to welcome a new born in the family.

    Probably it has to do with ‘double loading’ select 2 by this plugin and another plugin/theme. Please can you confirm this, and if so, can you see which version it is running?

    Let me know,

    Wouter

    WP latest. Avada latest. Select2 4.0.3

    I think so, this is the error:

    Uncaught Error: No select2/compat/dropdownCss
    at j (select2.min.js:1)
    at n (select2.min.js:1)
    at select2.min.js:1
    at D.apply (select2.min.js:2)
    at new e (select2.min.js:2)
    at new e (select2.min.js:2)
    at HTMLSelectElement.<anonymous> (select2.min.js:3)
    at Function.each (load-scripts.php:2)
    at a.fn.init.each (load-scripts.php:2)
    at a.fn.init.a.fn.select2 (select2.min.js:3)

    Plugin Author Mosterd3d

    (@mosterd3d)

    Thanks for your update!

    Still have one other question, because Avada is an premium theme, I can’t dive into the code, but hopefully you can! Can you check for me what the first value is of wp_enqueue_script which is calling their select 2? For example mine looks like this:

    wp_enqueue_script('select-2', plugins_url('/js/select2.min.js', __FILE__), array('jquery'), '');

    And I’m curious what they have in place as name of the script.

    andrewfitz

    (@andrewfitz)

    After a lot of scratching my head, it appears they have replaced it with the “selectWoo” library. Not sure how that works or why it’s causing conflict.

    Plugin Author Mosterd3d

    (@mosterd3d)

    Can you check if it works with the latest version 4.3.1?

    andrewfitz

    (@andrewfitz)

    Just tried, unfortunately still doesn’t work.

    It may have something to do with needing to use the full select2

    https://github.com/select2/select2/issues/2879
    https://stackoverflow.com/questions/30235909/using-select2-get-error-error-no-select2-compat-query

    I’m not sure, this is the only plugin that has caused any errors out of hundereds I’ve used. Thanks for your help!

    Uncaught Error: No select2/compat/dropdownCss
        at j (select2.min.js?ver=4.9.8:formatted:90)
        at o (select2.min.js?ver=4.9.8:formatted:174)
        at select2.min.js?ver=4.9.8:formatted:69
        at D.apply (select2.min.js?ver=4.9.8:formatted:2972)
        at new e (select2.min.js?ver=4.9.8:formatted:3086)
        at new e (select2.min.js?ver=4.9.8:formatted:3131)
        at HTMLSelectElement.<anonymous> (select2.min.js?ver=4.9.8:formatted:3478)
        at Function.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-color,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-posit&load[]=ion,underscore,moxiejs,plupload&ver=4.9.8:2)
        at a.fn.init.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-color,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-posit&load[]=ion,underscore,moxiejs,plupload&ver=4.9.8:2)
        at a.fn.init.a.fn.select2 (select2.min.js?ver=4.9.8:formatted:3476)
    j @ select2.min.js?ver=4.9.8:formatted:90
    o @ select2.min.js?ver=4.9.8:formatted:174
    (anonymous) @ select2.min.js?ver=4.9.8:formatted:69
    D.apply @ select2.min.js?ver=4.9.8:formatted:2972
    e @ select2.min.js?ver=4.9.8:formatted:3086
    e @ select2.min.js?ver=4.9.8:formatted:3131
    (anonymous) @ select2.min.js?ver=4.9.8:formatted:3478
    each @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-color,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-posit&load[]=ion,underscore,moxiejs,plupload&ver=4.9.8:2
    each @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-color,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-posit&load[]=ion,underscore,moxiejs,plupload&ver=4.9.8:2
    a.fn.select2 @ select2.min.js?ver=4.9.8:formatted:3476
    (anonymous) @ avada-fusion-options.js?ver=1.0.0:8
    i @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-color,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-posit&load[]=ion,underscore,moxiejs,plupload&ver=4.9.8:2
    fireWith @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-color,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-posit&load[]=ion,underscore,moxiejs,plupload&ver=4.9.8:2
    ready @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-color,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-posit&load[]=ion,underscore,moxiejs,plupload&ver=4.9.8:2
    K @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils,jquery-color,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,jquery-ui-posit&load[]=ion,underscore,moxiejs,plupload&ver=4.9.8:2
    andrewfitz

    (@andrewfitz)

    Fixed it, using the full min version worked!

    https://github.com/select2/select2/blob/develop/dist/js/select2.full.min.js

    If you could update it with that one, that would be great!

    Plugin Author Mosterd3d

    (@mosterd3d)

    See V3.4.2

    Thanks for helping and having the patience to solve this ‘vendor’ bug. Hope the plugin helps to let your sites more powerful! I would say ‘add a review’, but you already did! Thanks for that again. (donating is free ;))

    Please close this topic if it fits your benefits!

    Plugin Author Mosterd3d

    (@mosterd3d)

    √ Solved the problem and quiet at the other side!
    √ Closed it myself

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Activation causes editor to disapear’ is closed to new replies.