Support » Plugin: Yoast SEO » Activating Yoast breadcrumbs causes “incorrect value type @id” error on Google

  • Resolved sadiqodunsi

    (@sadiqodunsi)


    When I activate the yoast breadcrumbs, I get the following error on google search console and on structured data testing tool.

    Structured data with syntax errors detected
    Invalid items are not eligible for Google Search's rich results

    incorrect value type @id

    And Console highlighted this part on my website
    {"@type":"WebPage","@id":false,"url":false,"name":"Event Planning"}

    What is the cause of this?

    Kind regards,
    Sadiq

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We would like some more information.

    1. Can you confirm you are using the most recent Yoast SEO, v12.4? If you update, does the issue resolve?

    2. Are all your non-Yoast plugins and themes also updated?

    3. Can you confirm you are using WordPress 5.2.4? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/.

    4. Can you provide a URL that highlights the issue?

    Plugin Support amboutwe

    (@amboutwe)

    This thread has been marked as resolved due to a lack of activity.

    You’re always welcome to re-open this topic. Please read this post before opening a new request.

    Thanks for understanding!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.