Support » Plugin: Webcomic » Activating Webcomic Prevents Media Library Thumbnails Gallery from Loading

  • Resolved derekpadula

    (@derekpadula)


    Every time I activate Webcomic it prevents the media library’s thumbnails from loading in the gallery page. This also prevents me from attaching images on individual comics, posts, and pages because they use the gallery mode by default. Here is a video of the problem:

    All plugins and themes are up to date. I have disabled all plugins and switched to the default 2022 theme. When no plugins are activated, the gallery loads fine. Right after I activate Webcomic, the gallery fails to load. Instead, there is a spinning loading disc.

    I have tried deleting the current version of 5.0.6 and installing 5.0.5, but the problem persists. I tried using my custom theme. I tried updating from 5.0.5 to 5.0.6 and it broke my site and required deleting Webcomic altogether and then re-installing 5.0.6.

    I also tried modifying my permissions on files and folders. Directories are 0755. Files are 0644.

    In the meantime, a workaround is to add the comic pages, upload the images when Webcomic is disabled, re-enable it, and then use the Webcomic Attacher.

    Any idea what could be causing the media library image gallery to not load? It’s odd that they do load in the list view, as you can see in the video, but not in the gallery view.

Viewing 6 replies - 1 through 6 (of 6 total)
  • luckydee

    (@luckydee)

    I have the exact same issue! If anyone has any update (the author mainly) would be super great!

    what did you mean by”In the meantime, a workaround is to add the comic pages, upload the images when Webcomic is disabled, re-enable it, and then use the Webcomic Attacher.”
    Where is the webcomic attacher? When enabling it back up the only way to add an image is the uploader which is broken while webcomic is active Is there another way to upload it?

    Erin Ptah

    (@sailorptah)

    IME the plugin author checks the Github issues board more than this one, so you could try posting about it there:

    https://github.com/mgsisk/webcomic/issues

    Thread Starter derekpadula

    (@derekpadula)

    It’s called Webcomic Matcher. When Webcomic is activated, it’s located in the WordPress sidebar dashboard under Tools.

    The best way I’ve been able to get it to work is to select a comic collection and choose Title and Title for the two dropdowns. This works well because I make my image titles the same as my page titles. It will then show a list of pages that you’ve created that are missing images, and it will also show the orphaned images that are not yet associated with pages. Then you check the boxes for the ones you want to match up. Then click to associate them.

    So until this is fixed, you can upload your images, create your pages, re-enable Webcomic, and match them up.

    In my limited testing, you can also upload images while Webcomic is activated by using the ‘Media > Add New’ feature in the WordPress sidebar and selecting the list view button. It’s located underneath the “Media Library” heading near the top of the screen.

    Once your image is uploaded, you will see an “Uploaded to” header in the list view’s image details. Click “Attach” there and you can attach each particular image to any existing comic page.

    —–

    Lucky posted about this in Github:

    https://github.com/mgsisk/webcomic/issues/375

    Hope Mike will see either of these soon.

    • This reply was modified 6 months ago by derekpadula. Reason: Added a link to Github

    This issue resolves if you switch PHP back to 7.3. It won’t immediately start again if you update the PHP version after that, but it will eventually. As most hosts are starting the push to deprecate PHP 7.3 and 7.4, this plugin has a lot of updates to make to be compatible with PHP 8.0… :/

    Thread Starter derekpadula

    (@derekpadula)

    Thanks for the update on the PHP deprecation. I reached out to Mike by email to see if he’s aware of the problem and interested in resolving it.

    Thread Starter derekpadula

    (@derekpadula)

    Mike replied to me about the problem and has fixed it in the latest update to the plug-in.

    I sent a small donation to his PayPal to say thank you for continuing to support this plug-in. Anyone reading this may want to do the same.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.