Support » Plugin: Avatar Privacy » Activating plugin deactivates also Author’s avatar

  • Resolved wkasulke

    (@wkasulke)


    Hello Guys,
    first thanks for this privacy addon to satisfy the DSGVO.
    One thing we observed when running on our single-site: The activated plugin deactivates the shown avatars from the blog-authors. Is there a way to prevent this issue? I tried a test-comment with my gravatar.com registered email-address. There is no avatar shown in the comment, and also my author’s avatar is still invisible.
    Any hint about that?
    Best regards,
    Wolfgang

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author pepe

    (@pputzer)

    Users have to opt-in in their profile page. You can change the default for old comments via the filter hook avatar_privacy_gravatar_use_default (effectively making Gravatar use “opt-out”). See https://wordpress.org/support/topic/zulassen-von-avataren-fur-alt-kommentare/ for sample code.

    Hello pepe,
    thanks for the information, but I’m not a programmer and I don’t know where and how to change or to insert this. I’ve to contact someone how is able to do this … 😉
    Best regards,
    Wolfgang

    Plugin Author pepe

    (@pputzer)

    You’d add that snippet to the functions.php of your (child) theme. I might be making this into an option in a future version, but I’m not sure if it’s really a good idea (“opt-out” is a policy that’s not strictly compatible with the GDPR).

    Thanks a lot, I’ll give it a try. I think, strictly compatible with this GDPR only is to shutdown the Net …;-) Than we’re really on the save side, but what’s with our fun???

    It’s a bit strange. I added the snippet at the end of functions.php, but Gravatar is only visible when I’m logged in on the website with a second browser tab. Without being logged in, the browser only shows the anonymous gravatar, not only in the test-comments but also in the blog. Is that normal?
    Best regards,
    Wolfgang

    Plugin Author pepe

    (@pputzer)

    Did you clear your browser and/or WordPress page cache?

    Hello pepe, good morning !

    WP Supercache clearing did the shot. Now everything works like expected … 😉

    Many thanks for your help, wish you a nice day and also weekend !

    Best regards,
    Wolfgang

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Activating plugin deactivates also Author’s avatar’ is closed to new replies.