Support » Plugin: Do Shortcodes for All in One SEO Pack » Activating plugin brings up error messages in Admin

  • Resolved shaunbowen

    (@shaunbowen)


    Hi there, when I install and activate your plugin, I get the following error warnings in the website admin:

    Warning: array_keys() expects parameter 1 to be array, boolean given in /home/wandercr/ebos/wp-content/plugins/do-shortcodes-for-all-in-one-seo-pack/denra-plugins/classes/Framework.php on line 98

    Warning: Invalid argument supplied for foreach() in /home/wandercr/ebos/wp-content/plugins/do-shortcodes-for-all-in-one-seo-pack/denra-plugins/classes/Framework.php on line 98

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Denra.com

    (@denra)

    Hello @shaunbowen,

    Do you have the latest version installed?

    Even if this messages are displayed on activation only there is no problem with the plugin’s work and features. It will do it’s job.

    However we need to fix the warning if it appears. Thank you for leting us know.

    Hi there, yes it was the latest version, only just downloaded a few days ago. I switched off all the sections except meta title and meta description, and now the errors have gone.

    Plugin Author Denra.com

    (@denra)

    Hi,

    It is not related to the sections. It’s just making a warning on activating because the settings are still not saved for the first time in the database and they cannot be processed corerctly i.e. the default options are used. You may turn on any section/setting now and the warning should not appear anymore. We will clear this with the next update.

    I’m closing the thread as resolved now. Please re-open it if needed or open a new one.

    Thank you for using our plugin. Please leave a positive review if you like the plugin and it helps you. Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.