Support » Plugin: Really Simple SSL » activating network wide – settings not synced

  • Resolved dberdal

    (@dberdal)


    I apologize if this is user error vs a plugin issue.

    I’ve Network activated the plugin, and chosen the network wide ssl option. There isn’t a network settings screen, so I take that to mean that whatever I set on the root domain should sync to other network sites.

    I’ve enabled SSL on root site, but child sites still say: SSL is activated network wideSSL is not yet enabled for this site

    I even tried

    $network_options = array(
              'ssl_enabled_networkwide'  => TRUE,
              'selected_networkwide_or_per_site'  => TRUE,
     );
    
     update_site_option('rlrsssl_network_options', $network_options);

    as you suggested in a previous thread to force SSL on. It didn’t help in my case.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Normally if you click “activate SSL” on one of your sites, and have selected the networkwide option, it should set all sites as enabled. In your case this does not appear to be the case.

    Could you try to deactivate, then activate again, choose network wide, and activate SSL on the root site?

    Thread Starter dberdal

    (@dberdal)

    That’s what I had been trying, but I did it again just now with the same results.
    I also tried deleting the plugin and redoing the same, with still the result being that SSL was activated on root site, but child sites show:

    Options:
    * Mixed content fixer
    SERVER: apache
    MULTISITE
    SSL is activated network wideSSL is not yet enabled for this site
    ** Detecting configuration **
    plugin version: 2.5.11
    Already on SSL, start detecting configuration
    ssl type: SERVER-HTTPS-ON
    ssl not enabled, show notice

    I’m checking my .htaccess file and I see nothing from Really Simple SSL.

    On root site debug says .htaccess rules tested successfully. Should there be rules written in .htaccess?

    Other than W3TC Rules I have:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f 
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Really Simple SSL does not automatically insert .htaccess redirects anymore, this is an option that can be enabled separately.

    I’ll run some tests to see if I can reproduce it, and get back to you.

    Thread Starter dberdal

    (@dberdal)

    Sounds great, thanks for investigating. This is a dev site so I’m fine giving you access if that is helpful. Just let me know where you’d like credentials sent.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    You can fill in the form at https://really-simple-ssl.com/contact/

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    I have created a new version, which gives more control over multisite network settings. I want to do some more tests today and tomorrow, before releasing it to beta, but if you have the time to wait a day, you can test the beta version with a dedicated network settings page. This should fix issues like you currently are experiencing.

    Thread Starter dberdal

    (@dberdal)

    I’ve added a user account for you to my site. Let me know if you don’t receive it. I’ll look forward to trying out the beta.

    Thanks!

    Thread Starter dberdal

    (@dberdal)

    Also, I’m fairly certain that you’d consider this, but it is critical that the network wide options can play nice with domain mapping plugins.

    On my site I’m using a domain mapping plugin by wpmudev which allows me to have wp-admin at root url, but map public side of the site.

    For example: rooturl.com/child-site/wp-admin and child-site.com for the same site.

    This allows me to easily use ssl for logins, without the hassle of setting up ssl for all my mapped domains.

    Ps.
    If multisite is hassle, make it a pro feature… I’m happy to pay, and have you stick around! People using multisite are either making money or at least trying haha.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    I have received credentials but am unsure to who they belong to. Could you send another mail to confirm it’s you?

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    The beta version for Really Simple SSL with dedicated network support is now live. You can download it from https://github.com/rlankhorst/really-simple-ssl. Please let me know if this helps!

    Thread Starter dberdal

    (@dberdal)

    Hi Rogier, I just sent you an email confirming credentials. I’ve installed the beta but can’t find the network admin screen. Would you prefer to continue any further discussion here or by email? Either works for me.

    Thread Starter dberdal

    (@dberdal)

    For future reference by anyone reading this thread, the beta version linked above did solve the issue of not being able to control ssl from the network level.

    My issue of not seeing the network admin screen was due to the folder name in the beta. It should be uploaded manually via FTP, and you should remove the word “master” from the folder name if it exists.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘activating network wide – settings not synced’ is closed to new replies.