Support » Plugin: External Links » Activated The Plugin, Doesn’t Work

  • Wonderful plugin firstly. It’s going to save me a ton of time!

    I installed the plugin, activated it and selected the first check box of “Apply Globally” but it hasn’t seemed to work for some reason.

    Unable to pinpoint the exact reason for this. Tried clearing my browser cache of course, caching plugin cache, Cloudflare cache and even tried it in a different browser altogether but to no avail.

    Here’s the link to the page where I was testing whether the external links open in a new tab or not:
    https://dietbros.com/fat-burning/the-ultimate-fat-burning-foods-list/#How-Is-Peanut-Butter-Consumed

    I clicked on the PB&J anchor text and it still opens in the same window.

    Help would be greatly appreciated. Thanks much!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Mike Koepke

    (@mike_koepke)

    I am seeing the plugin processing the links:
    <a href="http://www.globalhealingcenter.com/natural-health/bromelain/" class="external" rel="nofollow">bromelain</a>

    And confirming you do have the setting on to open links in a new window? I would expect to see an attribute target=”_blank” on the links. I’m not seeing that.

    Thread Starter dietbros

    (@dietbros)

    Hey Mike,

    Thanks for the prompt response. My bad! I took the “open in new window” phrase quite literally and thought it would open as a pop-up and not a new tab. The issue has been resolved.

    Another quick question. If I disable the plugin, does it “unrewrite” the code or does it stay?

    Thanks!

    Plugin Author Mike Koepke

    (@mike_koepke)

    Perhaps I need to clarify around the new window. In the old days it would in essence open another browser window. With Firefox and tabs, the browser itself would control whether it was a new window or a new tab. So really it is a new window/tab. That is unless the user has some addon that disables it completely….

    The processing happens on the fly and is non-destructive to current page, post. site content.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Activated The Plugin, Doesn’t Work’ is closed to new replies.