Lightbox Plus Colorbox
[resolved] actions.class.php multiple errors help (5 posts)

  1. jollymoon
    Posted 3 years ago #

    wp-content/plugins/lightbox-plus/classes/actions.class.php on line 85
    I have multiple errors: http://www.edparton.com/blog

    Worked fine until the most recent update...now each page is splashed with all these errors... I read several of your posts here and maybe it is JQuery?? I am no expert... Help Please?

    lightbox plus seems to work, but I need to get rid of all these errors

    Thanks for your help...


  2. jollymoon
    Posted 3 years ago #

    I dug around a little bit and noticed at the bottom of my "view source" for the webpage the jquery.colorbox.js was loaded with a ?ver=1.3.20 I checked the directory : .../wp-content/plugins/lightbox-plus/js/jquery.colorbox.js and my version was WRONG... I reloaded a fresh copy of lightbox-plus (had the new version of jquery.colorbox.js) and all the errors disappeared...

    Evidently the online "update plugin" did not reload the correct version of the jquery file... had to do a manual upload...


    Thanks for your help

  3. Dan Zappone
    Plugin Author

    Posted 3 years ago #

    Uh, thanks, I think. ;-)

    Glad you were able to resolve it.

  4. Andrew Hewatt
    Posted 3 years ago #

    Dan, it's weird but this just happened to me as well. I was having trouble with a javascript form loading and went to investigate. Found that the version of colorbox was as jollymoon says (set to 1.3.20).

    I had the latest version of your plugin installed. Uninstalled (via my WordPress admin), reinstalled (via the admin site) and the problem persisted. It wasn't until I downloaded the zip from wordpress.org and uploaded it to the admin that it fixed it. Weird.

    Anyways, I saved the old files that had the issue if you'd like to check it out. You can contact me via HewattDesign.com.

    Thanks for the plugin,
    - Andrew

  5. jollymoon
    Posted 3 years ago #

    Now I am getting a weird error message.
    When you do a search and have several results to display the error does not appear.

    It only appears when you do a SEARCH on my blog and returns a NO RESULT or blank search query...

    here is the whole line from the page:

    Notice: Trying to get property of non-object in .../htdocs/blog/wp-content/plugins/lightbox-plus/classes/actions.class.php on line 139
    <!-- Lightbox Plus ColorBox v2.6/1.3.32 - 2013.01.24 - Message: -->
    <script type="text/javascript">
    <script type='text/javascript' src='http://www.edparton.com/blog/wp-content/plugins/lightbox-plus/js/jquery.colorbox.1.3.32.js?ver=1.3.32'></script>

    A small nuisance but I can't find out why Lightbox Plus is giving an error on a Search and not anywhere else??


Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.