Support » Plugin: Mailchimp for WooCommerce » action timed out after 3600 seconds

  • Resolved Pixadoro

    (@filesubmit)


    Hello,

    I’ve been trying to sync WC and MC (all latest versions), but at some point in WooCommerce/Status/Scheduled Actions I see MailChimp_WooCommerce_Process_Orders action timed out after 3600 seconds

    I have the latest versions of WooCommerce, WordPress and Mailchmp for WooCommerce.
    PHP: 7.2.28
    MySQL version: 5.5.5-10.3.22-MariaDB-log

    I’ve tried syncing with the default Twenty Tweny and only WooCommerce and Mailchimp for WooCommerece plugins enabled, but It stops while syncing orders.

    Coupons: ~267
    Products: ~219
    Orders: ~17013
    Customers: ~31000

    I’ve tried everything, please help me solve this problem.

    Best regards!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support khungate

    (@khungate)

    Hi @filesubmit, at first glance this sounds issue sounds like it could be a server caching issue as this user had with his hosting: https://wordpress.org/support/topic/running-resync1-and-then-cli-seems-to-work-but/page/2/.

    Do you have any caching services running that could be impacting the sync?

    Thread Starter Pixadoro

    (@filesubmit)

    Hi, @khungate, I don’t use caching plugin, but I used caching from cPanel, which my hosting provides. I disabled it, deleted MC plugin and started all over. The sync failed at
    655 / 17040 orders with action timed out after 3600 seconds.

    Plugin Author ryanhungate

    (@ryanhungate)

    @filesubmit If the job is timing out, that means something’s wrong with CURL on your server communicating with the API. Are you by chance able to get into the command line and run the Action Scheduler from the CLI instead? I would bet that setting it up that way you won’t run into any issues.

    Could you please give that a try?

    If you need to retrigger the order sync again where it left off, just go to your admin and add &restart_order_sync=1 into the query string and click return. You’ll queue up the job again where it left off.

    Thread Starter Pixadoro

    (@filesubmit)

    Hello, I didn’t have the chance to run from CLI since my hosting provider didn’t answer fast wnough, but I got “Your store is synced with Mailchimp!”

    What I did: I noticed that when I start the sync proccess a message stating that it is safe to navigate away from the windows, as the proccess is a background job. So everytime I closed the window and everytime it timed out. Last time I ran &restart_order_sync=1 and left the window open and active through the night and it finished the job successfully.

    So I guess the problem is something related to whether the tab is active or not.

    1/ Can you tell me if https://actionscheduler.org/perf/ speeds up the proccess of sync on large stores?

    2/ Few days ago I talked to MC support and they told me “that the CURL / OPEN SSL libraries need to be updated. In your System Status report we can see that HTTPS is supported, however the server is not using the proper http security standards for the API to accept the requests. Please upgrade to at least TLS 1.1 in order to push data as the store’s API is rejecting the calls.”.

    I’ve contacted my hosting provider and they updated the OpenSSL version ot 1.1.1d. They’ve also noted the following:

    “Please note that SSLv2 and SSLv3 support has been disabled in this OpenSSL version. In this case, it is appropriate to continue mailing support to Mailchimp on how to modify TLS 1.2 requests, which should correct the problem.”

    Thread Starter Pixadoro

    (@filesubmit)

    It actually synced 16943 out of 17053 orders and the opt in box is not showing on the checkout page.

    Thread Starter Pixadoro

    (@filesubmit)

    About opt in box is not showing on the checkout page – I noticed that the box disapears for some users – may be if they are subscribed – is that correct?

    Plugin Author ryanhungate

    (@ryanhungate)

    @filesubmit

    1. The action scheduler performance adjustment is most certainly a crucial tweak that you would want to make for your traffic it you’ve got a lot of orders / product updates / cart activity yes. By adjusting this to something appropriate for your traffic is important.

    2. If MC support said that the libraries needed to be updated, it could have been due to the nature of the question ( timing out ). We actually have a configuration override that if you need to specify a certain TLS version you may do so by using the constant – MAILCHIMP_USE_HTTP_VERSION so basically you could do something like this:

    define('MAILCHIMP_USE_HTTP_VERSION', CURL_HTTP_VERSION_2_0);

    By default we’re using CURL_HTTP_VERSION_1_1 but you may change it as I just showed.

    3. The opt in box should be showing if someone is not logged in, or if they are not subscribed. This is by design yes.

    Let us know if you have any other questions!

    • This reply was modified 3 years, 8 months ago by ryanhungate.
    Thread Starter Pixadoro

    (@filesubmit)

    Hi and thank you!
    I’ve placed define(‘MAILCHIMP_USE_HTTP_VERSION’, CURL_HTTP_VERSION_2_0); in wp-config.php
    and activated the Action Scheduler High Volume plugin. I noticed that not all orders were synced, so I started the proccess all over again, but again if I close the windows admin.php?page=mailchimp-woocommerce, the action times out.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘action timed out after 3600 seconds’ is closed to new replies.