Support » Plugin: Advanced Custom Fields » ACF removed native custom fields, cannot find data

  • laughoutlam

    (@laughoutlam)


    I have activated the ACF plugin however I am working with an older website and they have lots of data in the native custom fields. The issue is when ACF is activated, I can no longer access the data in the native custom fields – it just disappears. I have tried adding the code add_filter(‘acf/settings/remove_wp_meta_box’, ‘__return_false’);
    to my functions.php file however I get a Warning: Division by zero error
    Is there a way to quickly transfer all data from native custom fields to advanced custom fields, or a way to stop ACF from removing the native custom fields?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Same issue, but the native ones have not gone, they’re just no longer displayed. There are instructions in various support threads to switch their visibility back on, but under Gutenberg this doesn’t work. Checking the Custom Fields box under:

    Show more tools & options > Options > Advanced Panels: Custom Fields

    simply reloads the page but does not reveal them. The only way I could see mine again was to disable ACF. Not good. If I want to rigorously check data has come across correctly (even on a sample of posts) I guess I’ll have to do it in phpMyAdmin – and I’ve no idea how to subsequently delete the native fields once I’ve finished. I wish ACF had an option (tho not by default!) to ‘adopt’ native fields instead of hiding them but not actually doing anything with them.

    Anyway… apparently, you can migrate existing fields by creating ACF fields with the same name, then saving each blog post to populate the new one. But you have to make very sure you set up the ACF Groups structure correctly first, as you can’t move things around later without messing it all up. I shall feed back here if I manage to make this work (and if I find a way of mass-populating the replacement fields, rather than having to manually open and ‘Update’ each post individually.

    • This reply was modified 5 months, 2 weeks ago by wwwolf. Reason: minor typos

    There seem to be other odd things about using this with Gutenberg – I just tried to set a field to appear “High (after title)” and it simply didn’t change anything – field still appears down the bottom after the Post content.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.