Support » Plugin: WordPress Importer » ACF Image field value are not imported

  • bbormankd

    (@bbormankd)



    I have created a WXR export file for one post from a custom post type. The import works well except that all the image fields aren’t set. Not that the images didn’t get copied but that they don’t seem to have been given a value at all. If I run the test locally it works as expected, if I run the test on our staging server I get this issue.

    Digging into the database, I noticed that on my working local DB, the postmeta table has multiple entries with meta_key _wp_attachment_metadata where as the staging DB does not have any entries of this type. Doing some further debugging in wordpress-importer.php file, it appears that it never even tries to import attachments (from what I can tell).

    I also noticed that in the postmeta table there is a meta_key for the ACF image field with the correct post id for the attachment as the value, but in the posts table, the attachment post was never created. I was just curious if anyone could guide me through what else I could check to try and solve this issue.

    Given the fact it is working on local but not staging is the closest clue I’ve gotten, but checking against URLs in the WXR and database shows no issues as they match correspondingly. Also since it is not as if the images aren’t being copied, but instead the field and post itself aren’t being created makes me think it is skipping a step or something?

    Any help is greatly appreciated!

    https://wordpress.org/plugins/wordpress-importer/

  • The topic ‘ACF Image field value are not imported’ is closed to new replies.