Support » Plugin: Media Library Assistant » ACF Image: Button and Search box wrongly hidden

  • Resolved dafsade

    (@dafsade)


    Hi
    I’m using MLA along with ACF (for Image custom field).
    When I select an image from a ACF Image field I see the MLA fields (above the images) hidden, check this screen:
    https://i.postimg.cc/pdHNvdHG/1.jpg

    Inspecting the code and applying some brutal and dirty styles I see that all the fields are there, but covered by the images.
    https://i.postimg.cc/pTQLvS48/1.jpg

    So it’s impossible for standard users use it.
    Any way to solve it?

    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi,

    I just want to confirm I’m experiencing the same issue.

    Seems ACF may have changed some of their CSS on that screen, and it’s bumped the MLA fields to the next line.

    Andrew Nimmo

    Plugin Author David Lingren

    (@dglingren)

    Thanks to both of you for your reports. Thanks as well for the link to a screen shot showing the HTML markup and CSS styles behind the “Select Image” popup window; very helpful.

    I have not been able to reproduce this issue on my system. I see in the screen shot that the media-toolbar-secondary and the mla-search-box elements have explicit “flex” styles that are not present on my system. I believe these are responsible for the issue. Perhaps your theme or another plugin is adding them.

    If you can identify the source of these styles and tell me how to reproduce them I will investigate further. Thanks for your patience, your understanding and your interest in the plugin.

    Thread Starter dafsade

    (@dafsade)

    Hi David, thanks for answer.
    There’s a misunderstanding. The flex styles you see in my screenshot are applied by me, “live” in the browser inspector, just for testing purpose.
    Below you see the code as it is (no flex styles):
    https://postimg.cc/gallery/ntpsymB

    Plugins versions:
    – Advanced Custom Fields PRO 5.10.2
    – MLA 2.97

    Anyway, now it happens a strange thing: I tried to disable all plugins except ACF and MLA and the issue gone away. Now I enabled all plugins one by one to get what was the “bad” one. Well, after enabling all the problem never come back!

    I keep monitoring the situation
    Thanks

    Thread Starter dafsade

    (@dafsade)

    Sorry, issue is here again. 🙁
    It seems it re-appears after sometime from disabling/re-enabling plugins (?)

    Thread Starter dafsade

    (@dafsade)

    Get it, it’s “Disable Gutenberg” plugin:
    https://wordpress.org/plugins/disable-gutenberg/

    Disabling it the problem definitely goes away. Could you try it to reproduce the problem?

    Plugin Author David Lingren

    (@dglingren)

    Thanks for your excellent detective work. You can find a solution here:

    Conflicts with the Disable Gutenberg plugin.

    You can follow the instructions there and give the Development Version a try. Let me know if that works for you.

    Thread Starter dafsade

    (@dafsade)

    Solved! Many thanks David.

    For when is planned the “official” update?

    Plugin Author David Lingren

    (@dglingren)

    Thanks for your update with the good news regarding the Development Version.

    I do not have a scheduled “official” release date, but the Development Version has only a few small changes and is quite stable. You can feel confident about using it until the next official version comes out.

    @nimmolo – If you are not using the Disable Gutenberg plugin you may be more interested in this similar topic and the solution proposed there:

    Filter when inserting pictures does not work properly

    Let me know if either solution works for you as well; thanks.

    Thanks @dafsade and @dglingren !

    I’m using Disable Gutenberg too (because it dequeues frontend Gutenberg scripts, and Classic Editor does not) so I will stick with the Development Version, which also works for me.

    Thanks much!

    Arrived here due to the issue reported with search fields being hidden behind images, though I can’t confirm if it’s directly related to ACF or not.
    Screenshot: https://i.imgur.com/F3niQpA.png

    I read through the comments, but didn’t see any explicit reference to a fix other then downloading a separate “Disable Gutenberg” plugin, but that is not one we can install at this time.

    @dglingren Is this fix part of the next planned release? I did see mention to try and test with the dev version, but when I follow your instructions with the download link provided, it just asks me if I want to replace the existing MLA plugin, instead of adding a separate date based entry.

    Plugin Author David Lingren

    (@dglingren)

    @zxurian – Thanks for your post, and for taking the time to find this topic and do your research.

    You wrote “I can’t confirm if it’s directly related to ACF or not.” The issue fixed in the latest Development Version is not specific to ACF; it can happen to anyone.

    You wrote “but didn’t see any explicit reference to a fix other then downloading a separate “Disable Gutenberg” plugin“. The only fix required is to install the MLA Development Version. The “Disable Gutenberg” plugin is not required.

    You asked “Is this fix part of the next planned release?” The short answer is yes, although I do not have a scheduled release date at this time.

    You observed “ it just asks me if I want to replace the existing MLA plugin. That is correct; the Development Version replaces the existing version. Step two of the instructions says “Find Media Library Assistant and delete it. You will not lose any settings.”

    The latest Development Version has very minor changes from the current “official” version, and you can use it with confidence until it is automatically replaced by the next MLA update. You can always delete it and re-install the official version if you need to.

    I hope that answers your questions. If you have any problems or further questions regarding the fix or the Development Version, post an update here. It would be great to know if the Development Version resolves your problem! Thanks for your interest in the plugin.

    Plugin Author David Lingren

    (@dglingren)

    I have released MLA v2.98, which contains the solution for this issue. I am marking this topic resolved, but please update it if you have any problems or further questions regarding the issue or the solution. Thanks again for bringing it to my attention.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘ACF Image: Button and Search box wrongly hidden’ is closed to new replies.