Support » Plugin: WP LinkedIn » Acess token gives me 404 not found :(

  • Resolved oooskar

    (@oooskar)


    After clicking this button to get an access token: Your LinkedIn access token is invalid or has expired, please click here to get a new one.

    I get a page with my profile asking for authorisation to my profile. I clicked “allow” and then it gave me this: Not Found
    The requested URL /oauth/linkedin//wp-admin/options-general.php?page=wp-linkedin was not found on this server.

    I can’t figure out how to allow it or something. The message Your LinkedIn access token is invalid or has expired, please click here to get a new one. still remains 🙁

    Can someone help me out?

    • This topic was modified 1 year, 1 month ago by oooskar.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Claude Vedovini

    (@cvedovini)

    try going to the settings/permalinks page and press the save button, then try again to get a token

    Hey Claude,

    Thanks for your reply! Did you mean in the WP Linkedin application?

    I tried what you said in the WP Linkedin plugin, went to settings and saved them again. This didn’t help, I still get the same: not Found
    The requested URL /oauth/linkedin//wp-admin/options-general.php?page=wp-linkedin was not found on this server

    Furthermore, I tried going through all the steps on this page: https://vedovini.net/how-to-create-a-linkedin-api-application-for-the-wp-linkedin-plugin/

    It didn’t help as well 🙁

    Any ideas?

    Oskar

    Plugin Author Claude Vedovini

    (@cvedovini)

    no, I mean the permalink settings of WordPress

    https://codex.wordpress.org/Settings_Permalinks_Screen

    Dear Claude,

    Thanks for your message! Sadly saving the permalink didn’t help. I still get the same error message: not Found
    The requested URL /oauth/linkedin//wp-admin/options-general.php?page=wp-linkedin was not found on this server

    Could it have something to do with the fact that I haven’t implemented the plugin anywhere on my site yet? I just set up my website on Tuesday, so am still figuring things out. The website is OskarWolthoorn.com

    What do you think?

    Plugin Author Claude Vedovini

    (@cvedovini)

    no, it should be working. I see you are using HTTPS, can you check in the WordPress general settings that the “WordPress Address” and “Site Address” both have https?

    also make sur the redirect uri you gave in the LinkedIn API application is also using https (you can have both registered)

    Very strange!

    I can see in the general settings that it states “http://oskarwolthoorn.com“, so not Https, but http.

    I will try to make it both https! I think everything is http now.

    OMG THANKS! It worked!

    I installed an SSL certificate (my hosting provider offered me a one-click ssl-install for €15,- (probs pretty expensive). After that I installed the “really simple SSL” plugin to get my site to https instead of http. Then I followed all the steps to setup the linkedin plugin correctly (inluding making a new application for the token and everything). Finally, after getting the token it worked!! It now has one.

    Thanks very much for you help, Claude! 😀

    • This reply was modified 1 year, 1 month ago by oooskar.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Acess token gives me 404 not found :(’ is closed to new replies.