Support » Plugin: Authorizer » Account is pending although it is approved by admin

  • Resolved ysintos

    (@ysintos)


    Hello, I have a CAS server using SAML_1_1 and although i registed a user to a website and i approve it as admin, when i try to login with the new user i get the message
    “ACCOUNT PENDING: Your account is currently not active. An administrator needs to activate your account before you can login.”
    Any help with this ?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Paul Ryan

    (@figureone)

    Can you look at the entry in the Pending list and see if the email is different than your admin user? It sounds like the CAS attribute containing email address is not matching the email address of the user you created (that’s how CAS users and WordPress users are linked by default).

    There is no pending list. As admin i approved the user, so i don’t understand what you are saying about emails not matching.
    Should i send you a screenshot of the users list ?

    Plugin Author Paul Ryan

    (@figureone)

    Are you using any other plugins? The error message you quoted above is nowhere in Authorizer or WordPress core.

    I installed, but then uninstalled “User Role Editor” plugin and i also use “Toolset Access”
    Do you believe that thia causes the error ?

    I just deactivated both but the problem remains.
    The same error….

    Plugin Author Paul Ryan

    (@figureone)

    You’ll have to figure out where that error message is coming from, it doesn’t seem relevant to this plugin.

    I just tried it on a clean setup and it worked perfectly.
    So you are right, the issue is with some other plugin.
    Thank you very much for your help.

    Just to let you know, for anyone else that has the same issue in the future, the problem is caused from All in One WP Security.
    You should have the User Registration Manual Approval disabled.

    Plugin Author Paul Ryan

    (@figureone)

    Nice, glad you figured it out!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.