Support » Networking WordPress » Account activation on 'Members Only' site

  • Resolved sontru


    Is this a bug/issue or how it is supposed to work.

    I have a subsite that has it Privacy set to Members Only (I would like my blog to be visible only to registered users I add to “site”)

    When an admin user of this subsite creates a user, an email is sent for the user to activate the account. But when the user clicks on the activation link – the user is asked to log on instead!

    Is there something in my setup (like a security plugin) that is doing this or this the behaviour of a WordPress Multsite?

Viewing 6 replies - 1 through 6 (of 6 total)
  • In short, yes. WordPress by default sends out an activation link email, but a plugin puts up the login window before activation can be completed.

    You appear to be using my privacy plugin – it looks(behaves) like mine – More Privacy Options, I figure.

    I use this privacy plugin to control visibility(not registration) on a school site, so I do not mind the side-effect(or defect) of closing the door to new users or of the Network Admin having to manually approve all network users. It is clunky, but it is safer for my kids. And I generally keep registration closed so the runaround you see isn’t a need-to-fix for me.

    I also use User Activation Keys plugin to manually approve registrations that are “lost in the mail”. You will still need to manually edit a user profile and send out passwords if activated this way.

    Surely there must be away of allowing users to activate without blocking?

    You’ll need to hook into your user activation with a plugin so users are created and added without need of the activation email, or filter the activation url to a blog that is not user restricted. There was a plugin out there once upon a time I think. Something that adds users and sends their random password straight away. Some definite downside to that approach if you have a spammer in the midst. Users can turn off privacy settings when adding new users is best way I would use.

    Cheers for the replies and info. I thought it might be as easy as just unblocking the activation page (a page exclude list in the plugin) somehow…

    Try adding to the top of the plugin code
    if( strpos($_SERVER['REQUEST_URI'], 'wp-activate.php')) return;

    Works like a treat! Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Account activation on 'Members Only' site’ is closed to new replies.