Support » Plugin: Squelch Tabs and Accordions Shortcodes » Accordions not working

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Matt Lowe

    (@squelch)

    Hi Fred,

    This can be caused by a number of things, all of which are outside of the plugin and to do with the way that WordPress handles shortcodes. Basically if you see the shortcode codes in the page it means that Squelch Tabs and Accordions Shortcodes isn’t being handed your content, WordPress simply isn’t talking to my plugin (which is outside of my control).

    Usually it is to do with stray formatting being applied to the code caused by copying and pasting shortcodes, so that would be one of the first things to check. Recent updates to the WordPress Shortcodes engine have made it very fussy about what characters are allowed within a shortcode.

    First thing to check – and this may sound patronising, but it wouldn’t be the first time that this has happened – is that the plugin is definitely activated.

    Second thing to check is that in your shortcode codes all of the spaces are definitely normal spaces and not some other whitespace (there are a bunch of characters that look like spaces but aren’t, WordPress doesn’t like them). Go through each space, highlight it, and then press space to overtype it with a normal space.

    Then check that all of the quotes, e.g. “, are normal straight quotes. Select each quote and type a ” on your keyboard to replace it.

    Sometimes it can help to cut the shortcodes from the page and paste them into a text editor (e.g. NotePad on Windows, TextEdit on Mac, Vim on Linux/Unix).

    It might also be worth switching to the “text” view on the editor and checking that there is no stray html surrounding your shortcodes. e.g.

    BAD:

    
    <div class="shortcodes-code-block">[accordions title="" disabled="false" active="0" autoheight="false" collapsible="true"]</div>
    <div class="shortcodes-code-block">[accordion title="Pane 0"]Accordion pane 0 content[/accordion]</div>
    <div class="shortcodes-code-block">[accordion title="Pane 1"]Accordion pane 1 content[/accordion]</div>
    <div class="shortcodes-code-block">[accordion title="Pane 2"]Accordion pane 2 content[/accordion]
    [/accordions]</div>
    

    Good:

    
    [accordions title="" disabled="false" active="0" autoheight="false" collapsible="true"]
    [accordion title="Pane 0"]Accordion pane 0 content[/accordion]
    [accordion title="Pane 1"]Accordion pane 1 content[/accordion]
    [accordion title="Pane 2"]Accordion pane 2 content[/accordion]
    [/accordions]
    

    I have the exact same problem.

    I use them in a text widget and everything is as it should be. The code is clear and all ” are the right ones, but still it’s like the shortcodes are not getting picked up ?

    I have tried other plugins with shortcodes and they worked, so it’s not be course there’s something wrong with my WordPress install handling shortcodes.

    Just tried it in a post, there it works.

    Why don’t they work in the widget ?

    Plugin Author Matt Lowe

    (@squelch)

    Difficult to say. I take it you are using a plugin to allow you to use shortcodes in widgets? Can you paste your shortcodes?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Accordions not working’ is closed to new replies.