Support » Plugin: FP Foundation Assistant » Accordion multiexpand and allclosed support

  • adematte

    (@adematte)


    The plugin could easily support accordion multiexpand and allclosed together.
    Have to replace, for example in “class-wordpress-shortcodes-foundation-6.php” at line 207:

    if ( $atts['multiexpand'] == 'true' ) { 
    	$html = '<ul class="accordion'.esc_html( $class ).'" data-accordion data-multi-expand="true">';	
    } elseif ( $atts['allclosed'] == 'true' ) { 
    	$html = '<ul class="accordion'.esc_html( $class ).'" data-accordion data-allow-all-closed="true">';	
    } else { 
    	$html = '<ul class="accordion'.esc_html( $class ).'" data-accordion>';		
    }
    

    with:

    
    $html = '<ul class="accordion'.esc_html( $class ).'" data-accordion';
    if ( $atts['multiexpand'] == 'true' ) { 
    	$html .= ' data-multi-expand="true"';	
    }
    if ( $atts['allclosed'] == 'true' ) { 
    	$html .= ' data-allow-all-closed="true"';	
    }
    $html .= '>';
    

    Can this change be available in the official plugin?

  • The topic ‘Accordion multiexpand and allclosed support’ is closed to new replies.