Support » Plugin: Page Builder Gutenberg Blocks – CoBlocks » Accordion (IE/Edge browsers)

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Evan Herman

    (@eherman24)

    Hi @mitchellem

    Are the other accordions that you are using with the same settings that work also CoBlocks accordions?

    If they are, there is most likely something being loaded on the page where things are not working. Possibly some CSS or JS from another plugin? Without having a live site to test with, it’s hard to pinpoint where exactly things might be encountering an issue.

    Hi Evan,

    Thanks for your quick answer.

    It’s a WordPress Twenty Nineteen theme with only Coblocks plugin installed.

    Here is the link – https://emily-mitchell-test.000webhostapp.com/accordion-1

    (disregard the part with another page that works – it actually also doesn’t have accordion items closed by default)

    Thank you!

    Hi Evan,

    Thanks for your quick answer.

    It’s a WordPress Twenty Nineteen theme with only Coblocks plugin installed.

    I’ve sent the link to the live website, but reply with the link has been held for moderation.

    Hi Evan,

    The reply with the link has been published. Have you had any chance to check it?
    Thanks

    Plugin Author Anthony Ledesma

    (@paranoia1906)

    Hi @mitchellem,

    I got a look at your example site and I see what you are referring to. Getting a look at the source code, it looks like the polyfill for IE11 is not loading at all in your case.

    This screenshot here is from my personal blog where the polyfill is activated. This is the script which provides the accordion functionality to Edge and Internet Explorer.

    https://prnt.sc/pvhr3q

    My associate and I discovered that when “script_debug” mode is activated in your wp-config.php that the plugin will try and load non-existent files, thereby failing to load the polyfill on your pages. See if you have the following code in you wp-config.php file.

    define( 'SCRIPT_DEBUG', true );

    If so please change it to define( 'SCRIPT_DEBUG', false ); and see if the issue still exists. Please let me know what you find.

    Best,

    Anthony

    Hi Anthony,

    Thanks for your reply. No, debug mode is not activated on this installation. (the same issue happens on another server/hosting)

    Thanks.

    Plugin Author Anthony Ledesma

    (@paranoia1906)

    Hi @mitchellem,

    One thing here I am curious about is the fact that the polyfill is not loading at all nor does it seem to be generating any errors (such as a 404) when I inspect the network traffic. I have only been able to replicate that behavior when the polyfill is left disabled.

    Would you please edit your example page for me? I would ask that you add two sample accordions. Please enable polyfill for one of the accordions and leave the other accordion specifically disabled. Please let me know when that is done as I would like to look at the network traffic again. There ought to be a request made for that file if the feature is enabled.

    Best,

    Anthony

    Thank you, Anthony. I’ve edited the page – http://prntscr.com/pvsau8, http://prntscr.com/pvsb8f

    Regards.

    Plugin Author Anthony Ledesma

    (@paranoia1906)

    Hi @mitchellem,

    It looks like the example page https://emily-mitchell-test.000webhostapp.com/accordion-1 is not the one updated. I am basing that on the titles of the accordions in your screenshots. “polyfill enabled…” and “polyfill disabled…” respectively. Which page can I visit to see your updated accordions?

    Just for clarification, I am requesting you do this so I can help you identify what is going wrong. I have not been able to replicate the issue you are experiencing on my end except for script debug mode or if the polyfill is disabled.

    Best regards,

    Anthony

    Actually, it’s still the same page (http://prntscr.com/pw1ga2) – https://emily-mitchell-test.000webhostapp.com/accordion-1

    Regards.

    Plugin Author Anthony Ledesma

    (@paranoia1906)

    Hi @mitchellem,

    I see now. Thank you for that clarification. I see that the script is still not loading on your site when I visit. This one is a bit of a mystery so I decided to look into your host. I spun up a free test site on 000webhostapp.com to see if it was something local to that environment yet I still cannot replicate the behavior. Get a look for yourself:
    https://coblocks-test.000webhostapp.com/accordions

    Fully functional in IE and Edge. I did a default expert install, left the default theme and plugins, installed CoBlocks and went straight into a page to edit. After settings and publish its working as expected.

    Try to re-install the plugin perhaps? I might also advise to check the path of the script and see if its present in your hosting environment: wp-content/plugins/coblocks/dist/js/coblocks-accordion-polyfill.min.js?ver=1.17.1

    Let me know what you find. I am running out of ideas on how to help you here.

    Best,

    Anthony

    Hi Anthony,

    Thank you for taking time and uploading it to the same test environment. That’s really weird – as soon as I removed the blocks and added new ones, the issue has been solved, seems like some glitch.
    Sorry for the trouble and thank you for your help!

    Regards.

    moved to https://wordpress.org/support/topic/accordion-blocks-displayes-all-open-in-edge/

    • This reply was modified 1 month, 2 weeks ago by Rob Cale.
    • This reply was modified 1 month, 2 weeks ago by Rob Cale.
    • This reply was modified 1 month, 2 weeks ago by Rob Cale.
Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.