WordPress.org

Support

Support » Alpha/Beta » [Resolved] Accidently run the 2.1 Update instead of 2.0.5

[Resolved] Accidently run the 2.1 Update instead of 2.0.5

  • theworkisdone
    Member

    @theworkisdone

    Hi,

    well, sh*t happens: Yesterday I accidently rsynced the current 2.1-trunk with my Live-Site and run the upgrade-script, though I wanted just update form 2.0.4 to 2.0.5. Now all my ?page_id-Links don’t work anymore. And managing pages isn’t possible, there are no existing pages shown to manage. Though I still can access the pages with ?p=SOMEID.

    Is it safe to just copy over the 2.0.5 release? Any recommend desaster recovery strategies?

    Thank

Viewing 5 replies - 1 through 5 (of 5 total)
  • Sorry to hear that happened.. =( Um, from what I know, there was a few database changes from 2.0.? to 2.1 whatever.. You might be screwed at this point, sorry to say.. =(

    Um, maybe go in and manually get all of your blog articles, save them to a TXT file.. then, wipe out the blog.. re-install a new one.. using 2.0.5..? Good luck!

    Anyone else with suggestions..?

    spencerp

    Throwing this in here.. maybe try this import plugin once, to import from the screwed up blog, to another blog.. then make the newer blog the “MAIN” blog.. replace the screwed up one, with the NEW one..?

    spencerp

    JeremyVisser
    Member

    @jeremyvisser

    Hey there! All is not lost. WordPress 2.1 luckily has an export feature. Go to WP Admin → Manage → Export. This will allow you to download your posts into an XML-format file. Save that onto your hard drive.
    (By the way, if you’re using Firefox 2.0, you can’t do the export due to a bug in Firefox. If so, just use MSIE.)

    Then, delete your DB and WordPress and reinstall WP 2.0.5. Make sure you backed up first, though.

    Install the WordPress-to-WordPress import plugin (as WP 2.0.5 can’t import that XML file without a plugin) and use it to import the file that WP 2.1 spat out for you.

    Let me know how it goes. 🙂

    Thanks Jeremy for posting that! You just might be a huge life saver.. 😉 Unless of course.. the O.P. just decided to delete the WP blog and reinstall a 2.0.5 again sigh..

    spencerp

    theworkisdone
    Member

    @theworkisdone

    Hi, thanks for all your help. Before I was going to try your suggestions, I luckily solved my problem with the following.

    Since I had acces to all the pages with
    /?p=ID and
    /wp-admin/post.php?action=edit&post=ID

    I tried
    /wp-admin/page.php?action=edit&post=ID

    Saved it. Worked.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Accidently run the 2.1 Update instead of 2.0.5’ is closed to new replies.