Support » Fixing WordPress » accidentally deleted something =

  • I was trying to do something with the settings on the theme I was running, and I accidentally erased a part of a web address and now nothing on the Blog works. It just totally broke down and died and I have no idea how to fix it.

    I can’t even really describe what it was I did…I was in the settings and there was a line that asked for the site address and the index maybe? and the option said something along the lines of..change this if you have a different index page from the default page…or something like that, I don’t remember and I can’t get back to the page because nothing works…at all.

    Anyways the site is hosted at http://www.interlockingarchitecture.com/Blog and what I accidentally did was erase the work “Blog” from the end and now it’s totally screwed.

    Anyone have any idea what to do with this…?

Viewing 12 replies - 1 through 12 (of 12 total)
  • What I see when I go to the link is a notice that the PHP version is not high enough to use WordPress. You will need to upgrade the PHP version if you can or ask your web host.

    As for the setting you are describing, that can be changed through the database. If your host offers access to phpMyAdmin (perhaps through a control panel), you can edit that setting there.

    Yeah I’m getting the same message about the PHP version but it makes no sense. I was literally JUST on this site and updating it, and everything was working perfectly fine. I changed this one setting and everything fell apart. Why would I suddenly out of the blue be getting a message that my PHP is out of date? It makes no sense…

    Did you just recently (as in the time for this issue to happen), update the WordPress version?

    No, I haven’t updated the wordpress version anytime recently, definitely not anytime today.

    Everything worked flawlessly, then I accidentally changed the Site URL, and immediately this happened.

    I’ve found this page here http://codex.wordpress.org/Changing_The_Site_URL , it describes exactly what I did wrong and how to fix it…only, when I follow the instructions, nothing gets fixed.

    Did you try changing it in the database?

    I don’t know what you mean, sorry. I followed the instructions on that web site…

    As you scroll down the page (link you posted), you come to a section titled “Changing the URL directly in the database”. Did you try that?

    Oh…no, I did not. I don’t know if I’d be able to do that though, I don’t know what phpmyadmin is.

    It’s a “front-end” for allowing you to access the database. It comes with some hosting companies in their control panel.

    Okay, yes I read through it and changed those values. One of them was definitely incorrect in the Database, I corrected it. Still nothing though, does it take a few minutes to go through?

    Should happen right away. I would contact your web host regarding the PHP issue. If the host is running both PHP 4 & 5 side by side, there might be a line you would add to the .htaccess file.

    AddType x-mapp-php5 .php

    Yes I just found something on the host site to change the PHP version, it said I was using version 4. I switched to version 5 and now I get a totally different message when I try to go to the site:

    “Error establishing a database connection”

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘accidentally deleted something =’ is closed to new replies.