Support » Networking WordPress » Accidentally chose subdirectory!

  • Resolved khena25

    (@khena25)


    Hi!

    I enabled multisite the other day, but on the setup, I accidentally chose subdirectory instead of subdomains! What do I need to change in order to make this work?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Does your host support wildcard subdomains? Ask them first before you switch.

    Yes they do, and the wildcard is enabled!

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    go to your wp-config file. See the line that says SUBDOMAIN ‘false’?

    Make it say TRUE.

    Now go to the network setup page. it will say a network exists already, that;s fine. But the htaccess rules will be slightly different because you changed the config file.

    Copy the new htaccess rules and paste them in the file, overwriting the other ones.

    bmc2

    (@bmc2)

    Hello group,
    I have done this on my wife’s site. All working fine. I have buddypress installed, with a plugin called “site creation wizard”. When I switch over to ‘subdomains’, it throws this error:

    Warning: mysql_real_escape_string() expects parameter 1 to be string, object given in /home/*******/public_html/wp-includes/wp-db.php on line 774; It creates the blog, but not subdomain.

    Is this something I can fix? I am reading I may have to do a reinstall, but I hope someone can point me in the right direction?.

    Thank you for your time.

    Bert

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    bmc2 – You should disable all your plugins, THEN change it, then reenable them. Though BuddyPress may cause it’s own problems. I don’t know/remember if it caches any of that.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    with a plugin called “site creation wizard”.

    definitely disable that.

    bmc2

    (@bmc2)

    Thank you @ipstenu, @andrea_r. I have sussed that issue, but really do need to break down, and reinstall picking the subdomain.

    BMC2

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Accidentally chose subdirectory!’ is closed to new replies.