WordPress.org

Support

Support » Localhost Installs » accidentally changed the url in general settings

accidentally changed the url in general settings

  • Hello,

    Be easy on me…newbie and novice.
    I was trying to follow a lame (now I realize after the fact) tutorial on moving my wordpress site from xampp local host to live server. I changed the url http://localhost/wp_susanallen to http://susanallen.com and then i exported the mysql database. Now I can’t get back into my local host? Is there a fix for this? I seriously don’t want to loose all my work.

    Thank you in advance for your help.

Viewing 15 replies - 1 through 15 (of 17 total)
  • esmi

    @esmi

    Forum Moderator

    I miss Diva 🙂

    So happy for the quick response! So if I understand the link you provided is to follow the whole page of instructions? 🙂

    Opps (Hi miss Diva) typo

    esmi

    @esmi

    Forum Moderator

    No – just chose one of the 4 methods described. If you can, I’d suggest using No.2 “Edit functions.php”.

    I see. I’ll try that.

    It was so easy! I’m up and running on my localhost.

    TY TY

    Well, kind of. When clicking on the pages it points me to phpmyadmin. I almost have it figured out.

    Had to change my permalinks and all is well. You guys Rock!

    Okay I actually just made this same exact mistake, only I can’t fix it. I tried both methods listed on that page and the site is still inaccessible. Any ideas…?

    Hi DLHitchins,

    I hope I can post this link here.http://www.tamba2.org.uk/wordpress/site-url/ This is what I did and then after that I changed my permalinks back to default. Mind you this is all on my localhost xampp. I can’t say it will work for you…but I’m a happy camper.

    Hope this helps

    Hello
    I hope that will be useful
    (Change URL).

    Hey.
    This is kind of on the same theme:
    I’m in all sorts of trouble – I created a site on localhost using MAMP (on Mac).
    The site was working absolutely fine. I wanted to upload it to an existing site, overwriting the old one. I moved old files into a backup folder and uploaded the new site but it didn’t work – i think because I needed to change permalinks first.
    I went back to the site on localhost and changed the address in the permalinks settings and now I can’t access anything – I’m really panicking!
    Please could you help me regain access to localhost and then recommend a tutorial on how to upload the site properly…
    As usual, I thought I knew what I was doing a lot more than I actually did!

    It’s alright – scrap that last comment! I recreated my wordpress root folder from a backup, followed Esmi’s awesome advice and BINGO! Can’t thank you enough…I was seriously sweating!

    thanks emsi
    saved me I stupidly change the blog site settings and could not log in
    edit the current theme function with those 2 lines of code fixed it
    thanks
    cheers
    dan

    Okay, i switched out both the URL’s and don’t know how to access my wp-config.php and i don’t think there is an FTP page. Please help. My site is impactzonegolf.com and i switched it accidentally to getimpactzone.com

    Thanks

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘accidentally changed the url in general settings’ is closed to new replies.