• Hi,
    I am testing this plugin on my experimental site because want to remove S2Member.

    I found an interesting behaviour. I set “apply custom access settings” to members/admin or who is logged. An article with this limited access settings doesn’t open as it must be at the first click. BUT with second click you can read that article (even you’re not logged in). May be I described it not very clear: after the first click on the article it leads to login page, then click on home and back to this article.
    If I use shortcodes for logged users – it works very well (i.e you can not get access in spite of multiclicking of reloading etc.
    Additional info:
    – Multisite (two sites)
    – Twentyfourteen theme
    – WP Super Cache plugin
    – Yoast SEO
    – Yet Another Related Posts Plugin

    Actually, I like this plugin and I would like to install it to my “normal” site. Please fix this problem.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Ultimate Member Support


    Hi @deyneko,

    Can you please attach the screenshots of your access settings widget.
    Please consider performing conflict test so we can rule out any conflicts with other plugins. How to do a plugin/theme conflict test?


    Thread Starter Deyneko


    I found that access to restricted pages/posts appears when WP Super cache is active and cache is enabled.
    If WP Super cache is not active (by network deactivating), disabled (on all blogs), cache is deleted (in all blogs) – Ultimate Member plugin works apropriate.

    I logged in one browser (Mozila Firefox) and tried to get access to posts/pages via other – Internet Explorer 11 (without logging in). The access to restricted publications happens not always, sometimes I need to close Internet Explorer and delete cache in the browser – then I can get access to a restricted page by several clicks. The inappropriate access never happens from the first click, it happens after several clicks. I.e. – I do the first click, then loging page appears (as it must be), then I press “home” and again on that article and after second time (or more) I can see contens of a post/page (wich access only for admin).

    I did not did any special setting in the Ultimate Member plugin. I switched on custom access settings -> Content accessible to Logged In Users ->admin.

    The Twenty fourteen theme doesn’t conflict with the plugin as well as Twenty fifteen.

    Main settings in the WP Super cache plugin: “Use PHP to serve cache files.”

    Hope this helps.
    I can give you admin access to my experimental site because there is no any valuable information (it is just for experiments).

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Access settings doesn’t work’ is closed to new replies.