Support » Plugin: LifterLMS » Access Plan Showing Unwanted Text

  • Resolved dr_dad

    (@dr_dad)


    I created Course Description using LifterLMS course setup. I created Sections and Lessons with video in the Course Builder. I published the course: TH001 – Introduction to Bible Doctrines. I then created an eBook (pdf format) for each course section. I learned that I had to use the Assignment tab in Course Builder. Upon accessing the Assignment tab I got a message stating I needed to purchase the addon for Assignment. As these courses will all be free and I’m on a seriously limited income (SS) I can’t afford to purchase the addon. I decided to use Elementor to create a Bookstore tab which would contain links to the eBooks. I wanted to add a statement as to how to access the eBooks on the LifterLMS course page. Therefore, in Course Builder, beside the Course Title, I click on the WP icon. I was carried to Edit with Elementor. I created 3 sections on the Elementor page with the text I needed. I published the course page. Now all that I created is showing in the Access Plan on my website (see the link above), but not in the Elementor page. I don’t know how to fix this. I can’t access the LifterLMS original course setup. I would hate to delete this course and start over.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 16 through 19 (of 19 total)
  • dr_dad

    (@dr_dad)

    Natalie;

    You might want to review the above thread replies for July 9, 12 and 13. Here is Thomas’ thread reply for July 12:

    This is a bug in the LifterLMS core that I’ve been struggling to find an acceptable resolution for for several weeks. The bug report can be found here: https://github.com/gocodebox/lifterlms/issues/777

    Essentially what happens is the presence of a “Classic Editor” block copies the content of that block into the access plan description.

    I’ve tried dozens of different things to fix this but I can’t find a solution other than simply NOT USING classic editor blocks on courses.

    I haven’t found a really good reason why this isn’t an acceptable solution (other than it’s annoying and a bug is a bug).

    You can convert the classic block to other blocks (paragraphs, images, videos, etc…) and then delete the content from the access plan and you’ll be good to go.

    WE will get the bug fixed at some point but this is the only solution I have available to you at this moment.

    Let me know if that helps,

    Post Link: https://wordpress.org/support/topic/access-plan-showing-unwanted-text/#post-11727173

    My reply is under Thomas’ post.

    Thanks For Everything!!!

    dr_dad

    (@dr_dad)

    I tried to fix the Access Plan for TH001-Introduction to Bible Doctrines. All of the fields in the Access Plan are filled in correctly. The Plan Description has two tabs – Visual and Text. In Visual tab is clear, but the Text tab is populated with the unwanted text.

    I deleted the Access Plan and created another Free Access Plan. That didn’t work either. The old Plan Description text came back, even though i entered into the Plan Description box “All GCLC’s courses are free to registered users.” My new text was replaced with the corrupted former plan’s text.

    Here are screenshots to document what I did. The shared status reads: Can view.
    Anyone with this link can view the file.

    https://www.dropbox.com/s/17fpktwo3a7ov86/Access%20Plan%20-%20July%2018.pdf?dl=0

    From above, Thomas indicates that there is a bug in the Access Plan software. To fix it he wrote: “You can convert the classic block to other blocks (paragraphs, images, videos, etc…) and then delete the content from the access plan and you’ll be good to go.

    I can’t figure out how to do this! Can you explain more fully?

    Thanks

    I used Mozilla Firefox browser to access my website’s dashboard. I chose the course, Introduction to Bible Doctrine, that I couldn’t remove the unwanted text in my Access Plan (Pricing Table). I was able to create another Access Plan, Saved it, and saw it appear in the course description area. I updated my website, open my website in another tab, selected the course, but the Pricing Table wasn’t there.

    I went back to my dashboard to LifterLMS Settings, Checkout and marked Manual checkout. The LifterLMS/WordPress Help site provide the information that for free courses they needed a checkout gateway activated. It said that I could go into Settings, Checkout and mark Manual Checkout. I did this. I’m still not seeing the Pricing Table and Access Button in the course.

    I did the same thing with Google Chrome browser, with the same results.

    At least progress was made. I was able to create an Access Plan and see it in the course description area.

    Plugin Support Natalie

    (@nrherron)

    Hi @dr_dad,

    I apologize for the delay in response!

    It looks likes you were able to remove the text from the access plan in the mean time?

    https://www.dropbox.com/s/z53ozjz1t2dfodf/unwanted%20text.png?dl=0 This is what I see when I go to the course page! Is this the correct format or are you still seeing the issue on your end in the Firefox browser?

    Let us know if you have further questions!

    Thanks and take care,

Viewing 4 replies - 16 through 19 (of 19 total)
  • You must be logged in to reply to this topic.