• Resolved nicecms

    (@nicecms)


    Since 7/17 there have been no new entries to the access log, except for my own visits to our Digital Ocean-hosted site, which I visit from a separate browser instance. Tracking Mode is “Client”, Set Cookie is off, Visit Duration is 15 seconds, Enable CDN is off but that setting doesn’t seem to matter. My own visits appear in log with WP Fastest Cache both enabled and disabled.

    TIA

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    Hi @nicecms

    could you please post the URL to your website so that I can run some tests on my end?

    Thanks,
    Jason

    Thread Starter nicecms

    (@nicecms)

    Thanks Jason. It’s EARN.

    • This reply was modified 4 years, 11 months ago by nicecms.
    Plugin Author Jason Crouse

    (@coolmann)

    Are you using the Preload Cache feature in WP Fastest Cache? If that’s the case, you will need to allow tracking of bots in Slimstat, because WPFC will generate its own cache by crawling the website as a spider. If Slimstat is configured to ignore bots, it will NOT attach the javascript tracker to those requests (since it detects WPFC as a bot) and hence all the cached pages will NOT be tracked in the end. You can still use the Exclusions settings to not track Google and other bots, while allowing WPFC.

    I hope this makes sense.
    Jason

    Plugin Author Jason Crouse

    (@coolmann)

    Thread Starter nicecms

    (@nicecms)

    I’ll try disabling Preload Cache, which is enabled by default in WP FC. Should that fix the issue?

    The thread you refer to says, “Yes, the most recent version of Slimstat has the issue fixed, because WPFC would appear as a “bot” so there were some hangsup. All sorted now.”

    Thanks

    • This reply was modified 4 years, 11 months ago by nicecms.
    Plugin Author Jason Crouse

    (@coolmann)

    Yes, that is correct. The issue is fixed by disabling the option to NOT track bot.

    Keep me posted!
    Jason

    Thread Starter nicecms

    (@nicecms)

    Ok, the option to not track bots is off, and Preload is disabled in WP FC, but still visitors aren’t showing up in the Slimstat access log, though they’re in the Wordfence log. Many of the Wordfence log entries appear don’t have a “/” Page Visited entry, but only a “/wp-json/…” Page Visited. That’s from Popup Maker’s popup window that appears after 45 secs. Could there be a conflict between Popup Maker and Slimstat?

    Plugin Author Jason Crouse

    (@coolmann)

    Hi @nicecms

    Just to clarify, did you make sure the cache was cleared after you disabled the Preload option? Sometimes the cache is not cleared when you select the corresponding button in WPFC, so it’s always better to delete the content of the cache folder using your favorite FTP client. I still see a timestamp from earlier today on many of your pages. It doesn’t look like a conflict with Popup Maker at this stage.

    Jason

    Thread Starter nicecms

    (@nicecms)

    Just to clarify, did you make sure the cache was cleared after you disabled the Preload option?

    Yes, I think so, and the timestamp you saw would make sense since I disabled the preload option earlier today.

    I just used the WPFC button to clear the cache and I see that the timestamp of the home page now reflects that.

    The fact that only my own visits appear in the log doesn’t make sense to me:

    My own visits appear in log with WP Fastest Cache both enabled and disabled.

    • This reply was modified 4 years, 11 months ago by nicecms.
    Plugin Author Jason Crouse

    (@coolmann)

    The fact that only my own visits appear in the log doesn’t make sense to me

    That’s because there’s an option in WPFC to serve “fresh” content to logged in users or something (I don’t have installed anywhere right now, so I can’t double check). However, I just visited your website, and I see that the tracker recorded my activity. So, it looks like it should be working now. Can you confirm?

    Thanks,
    Jason

    Thread Starter nicecms

    (@nicecms)

    It’s working at least in part. I see your visit in the log and others but the log is missing visits from other ip’s that are unlikely to be bots and that visited “/wp-json/…”, which I assume means they were on the page for 45 secs and triggered the popup. If they triggered the popup then I’d think they’d be tracked in Client Mode however they’ve set their script blocking browser extension options.

    Googlebot started appearing in logs so I added a list of googlebot ip ranges to the Exclusions list (https://evert.meulie.net/faqwd/googlebot-ip-ranges/).

    • This reply was modified 4 years, 11 months ago by nicecms.
    • This reply was modified 4 years, 11 months ago by nicecms.
    • This reply was modified 4 years, 11 months ago by nicecms.
    Plugin Author Jason Crouse

    (@coolmann)

    Please consider writing a review for Slimstat as a token of appreciation for the support you received. It would be a nice way to say thank you and to let people know how much you value this plugin:

    https://wordpress.org/support/plugin/wp-slimstat/reviews/#new-post

    Thread Starter nicecms

    (@nicecms)

    I edited my reply above just after you replied to it. Thanks for your help. I’ll be sure to submit a review.

    Plugin Author Jason Crouse

    (@coolmann)

    It might be that those visitors still have the older version of your website cached locally. Does your server set an Etag HTTP header? I would give it some time to see if things change.

    Jason

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Access log has no new entries since 7/17’ is closed to new replies.