Access forbidden...403 (6 posts)

  1. saxeine
    Posted 10 years ago #

    I have a new installation that works fine except that I cant add any html elements/tags ,even from the toolbox in 'write post'...b/link-/img etc.
    The minute I add any tags/elements it produces:-
    Error 403 Access forbidden!
    You don't have permission to access the requested object. It is either read-protected or not readable by the server.
    I tried to give the complete wordpress files/folders full read/write access and tried installation with /without .htaccess file to no avail.
    Image upload ONLY uploads .gif files successfully all others (.jpg,.png etc )goes through the motions but no files are uploaded.
    but even the .gif file I can't add to posts with the supplied link...it generates 403's .Posts without any tags/elements work fine

    My platform is:-
    win 203 server/Apache/2.0.52 (Win32) mod_perl/1.99_15-dev Perl/v5.8.4 PHP/5.0.2

    what can I do please??
    Thanks in advance

  2. justinbaeder
    Posted 10 years ago #

    Do you mean it gives a 403 error when you try to save the post? I'm guessing some of the files in wp-includes may not have their permissions set properly, especially the file or files that validates post contents, hence the error when you incorporate HTML. But if you've checked that, I don't know.

    Sorry to ask a potentially insulting question, but you're using HTML, and not BBcode or wiki formatting, right? Just trying to think if things that could throw off the tag-closer/validator.

  3. saxeine
    Posted 10 years ago #

    Yes it gives a 403 error when you try to save the post......yes im using straight html code...thnx

  4. saxeine
    Posted 10 years ago #

    Is there still no solution to my above posted problem..I've tried installing on another computer under
    a slightly different enviroment(php4 instead of 5 as I suspected it may have to do with phph itself) but receive the same 403 error...as stated before can list and add new blogs but no images or anything that uses html tags.
    olz lend some suggestions
    thanks in advance.

  5. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Can you save the entry that does this as a .txt file and upload it to your website ? We can take a look then.

  6. rxaviers
    Posted 10 years ago #

    This error has to do with the "RewriteRule" directive into .htaccess. Maybe your Apache's configuration has anything on not accepting that.

    You can configure WordPress on using different ways for passing posts information, though. One of them (and this one maybe is set for you) uses this Apache directive for redirecting the URI throw index.php, another one is by passing variables throw GET (you should try this instead), Go to:
    ADMIN/OPTIONS/Permalink (choose the default).

Topic Closed

This topic has been closed to new replies.

About this Topic