Support » Localhost Installs » Access denied to my theme images.

  • Resolved Aryahell


    Hello all 🙂

    I am currently working on a WP website and a the moment I am working locally with Wampserver. None of my pictures happen to appear on my website.

    Here is the error I get when I put the image url in my browser :


    You don’t have permission to access /appetitclic/wp-content/themes/Apc/img/logo.png on this server.

    I have no problem accessing phpmyadmin and image from TewentyTwelve template work fine.

    Things I have tried :

    -Editing (and creating) .htaccess in wp-admin.
    -Editing phpmyadmin.conf
    -Puting Wamp on online mode
    -Working through instead of locally.
    I am pretty sure the problem doesn’t have to so with the code because I have access to the /appetitclic/wp-content/themes/Apc/img/ folder and I see the list of images (not working). I maybe missed one or two workarounds but I am pretty sure I tried most of the common ones.

    If you need any info on my setup / configs I have tried ask away.

    Thank you very much, Cheers.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi Aryahell,

    More than likely, you have some file permission issues. Please check out this post: Locally Installed WordPress Media Library Problems and the documentation Changing File Permissions.

    This is definitely permission issues. The way my server is set up each time I add something new to my WP directory I have to give it more permissions because of my security settings.

    I’m not familiar with WAMP server. (I used it maybe twice nine years ago in high school. I’m sure it’s been updated since then.)

    I run a LAMP server and I love it because all I have to do is run

    chmod -R 775 /path/to/directory

    And all files and folders have a new permission. Look into how to do it on a WAMP.

    Thank you for taking time to answer !

    Unfortunately I didn’t manage to fix my problem and after trying everything I could find on the internet I had to use my personal computer because the problem seemed to come from the network in my office.

    Cheers !

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Access denied to my theme images.’ is closed to new replies.