• jorritgo

    (@jorritgo)


    Access denied. This is funny as I can hop on the phpMyAdmin, with the username listed in the code, and no password. Any ideas?

    Getting hseet with code:

    <b>Warning</b>: mysql_query(): Access denied for user ‘chinaene’@’localhost’ (using password: NO) in <b>/home/chinaene/public_html/wp-content/plugins/wp-csv-to-database/main.php</b> on line <b>96</b>

    <b>Warning</b>: mysql_query(): A link to the server could not be established in <b>/home/chinaene/public_html/wp-content/plugins/wp-csv-to-database/main.php</b> on line <b>96</b>

    <b>Warning</b>: mysql_num_fields() expects parameter 1 to be resource
    boolean given in <b>/home/chinaene/public_html/wp-content/plugins/wp-csv-to-database/main.php</b> on line <b>98</b>

    https://wordpress.org/plugins/wp-csv-to-database/

Viewing 16 replies (of 16 total)
  • This is a new example about this WordPress failed database connection topic:
    “We were able to connect to the database server (which means your username and password is okay) but not able to select the XXXXXX database.”

    I have installed MySQL 5.7.17 and MySQL WorkBench 6.3.8. And WordPress 4.7.2. The MySQL was installed after removing both an earlier version of MySQL and WorkBench. The previous version was displaying the same database error. The previous WordPress/MySQL worked about 2 years ago, but recently I contracted a project to develop a WordPress Web site, and I encountered this problem when I began setting up the WordPress framework for this new site.

    So, I reasoned, why not try a fresh start and also upgrade to the latest versions, etc.

    But, this new version also had the same problem with not being able to connect to the database. I have narrowed down the problem to “permissions” and I haven’t been able to crack the code.

    The MySQL Server logs verify this is this case:
    Timestamp, Thread, Type, Details
    2017-01-28T02:46:24, 134, Note, Access denied for user ‘root’@’localhost’ (using password: YES)

    I have created a new WP directory and installed a fresh WP version etc.
    I deleted and created new databases in WorkBench and properly assigned them users and passwords.
    I have checked the Users and Privileges, Client Connections and can find nothing that would block access to the database.
    I have checked my Windows 7 permissions for the MySQL Directory and the sub directories. I have unchecked the “Read Only” to the master MySQL Directory and all directories and files are read/write.
    I have progressed through each attempt to connect to the database each time I change something.
    I am exhausted and very disappointed there isn’t a good response by the WP Support Team to this issue of “not able to select the database.” It is a “popular” issue that many developers are experiencing with no resolution–many more experienced than me, are having.

    I did find one article that was helpful, and I tried everything suggested, but could not fix my problem. I recommend it:

    http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-error-establishing-a-database-connection-in-wordpress/

Viewing 16 replies (of 16 total)
  • The topic ‘Access denied for user’ is closed to new replies.