Access Denied Following Permalink Structure Change (9 posts)

  1. Dat Bloke
    Posted 8 years ago #

    Aaaaaargh!!!! <<<< sound of own hair being ripped out.

    Last november I changed the permalink structure for my archives.

    WordPress is making available the older archives - prior to that change - under the old permalink structure but trying to link to those archives using the new permalink structure.

    http://freedomforall.net/?m=200506 is the old permalink structure and that page displays the June 2005 archives (STILL).

    http://freedomforall.net/2005/06/ is the new permalink structure and links are being displayed in this structure however when you try to click on any of the archive links prior to the permalink structure change you get an access denied error.

    I dont think this is due to .htaccess issues as the page under the old structure still displays.

    Hope there's an easy answer :D


  2. Jeremy Clark
    Posted 8 years ago #

    A .htaccess error is exactly what it sounds like. You don't have to a .htaccess file to display the default permalink structure (Microsoft IIS). The first thing I would check is the contents of your .htaccess file and look for something along the lines of Begin WordPress with some lines of code and then End WordPress. If you see something like that then most likely apache isn't setup to allow redirection. If thats the case I'd need further info about your server to help. Sorry there's not an easy answer.

  3. Andrew Ozz
    WordPress Dev
    Posted 8 years ago #

    Or perhaps upgrading to 2.1.3 will help... There are a lot of fixes since 2.0.5

  4. You are correct that it's not an .htaccess issue, since other permalinks on your pages work okay.

    Go to Options->Permalinks and click "Update Permalink Structure". See if that fixes it.

  5. Dat Bloke
    Posted 8 years ago #

    My .htaccess file is as follows. I have placed it in the root directory from where the blog is served and aso in the wordpress directory.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Does that help???

  6. Dat Bloke
    Posted 8 years ago #

    tried options update permalinks that did nothing (indeed I had already done that)

    also ,.... that .htaccess file pasted above doesnt have begin wordpress ... etc ... ???

  7. Jeremy Clark
    Posted 8 years ago #

    Disregard my earlier post your .htaccess file is fine I was at work when I posted the first time and for some reason or content filter blocked me from seeing you blog. After visiting at home I see that indeed you permalinks are working. The only thing I might suggest is going back to one of your early posts before you changed your structure and just editing and saving that post again then trying to go to the archives that the post was in and seeing if that helps.

  8. Do you actually have directories named /2005/06/ and so on? That would cause this sort of thing.

  9. Dat Bloke
    Posted 8 years ago #

    I've changed the structure back to the oldf one. its not what i want but its working .

    yes i have those .. my old directories had that structure and i have individual redirect pages in there cos loads of my traffic still comes to old indexings of those pages thru search engines

    Is that what's doing it?

Topic Closed

This topic has been closed to new replies.

About this Topic